LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-26-2006, 09:03 PM   #1
mybootorg
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Rep: Reputation: 0
Arrow Correct desktop resolution. Incorrect screensaver res (SOLVED)


I'm running Ubuntu 5.10 w/ Gnome on a Dell D610 Latitude Laptop. (Though I think the actual distro is probably less important as I've seen the same problem posted -- but not resolved -- by folks running Fedora etc.)

I'm docked and hooked up to a Dell 2001FPS monitor running at 1600x1200 resolution. My video card is an ATI Radeon Mobility M300 (M22) running on the "fglrx" driver.

The problem I am having is that when my screensaver starts, or I go to lock my workstation on my way to lunch, the lock screen or screensaver comes up at what looks like 1024x768 - in a smaller window - leaving the rest of my desktop exposed beneath it.

I feel like I have a pretty good grip on the possible locations of the .xscreensaver files and how to configure them. And also, I'm fairly certain I have xorg.conf set up properly (though I'm including it at the bottom of the post). Likewise, I have no other problems with resolution except when the screensaver or lock screen comes on. I can punch in my password and I'm back to my desktop @ 1600x1200 without any problems.

It "feels" to me like the screensaver is pulling its default resolution from somewhere other than what's currently running in Xserver, and somewhere other than the /etc/X11/xorg.conf file. But for the life of me, I can't figure out where or why this is occuring.

It should be noted that I originally installed Ubuntu 5.10 without the Dell Flat Panel attached and using the default resolution of the laptop LCD panel which *is* 1024x768. I doubt an installation would hard code such a thing as a base resolution, and if so, I see no way to change it in the GUI. However, the other posts of this problem that I've googled were of a similar variety - someone upgraded their monitor, got their monitor resolution correct, but their old resolution stayed on to haunt their screensaver and lock desktop.

Thanks in advance,

Craig Mitchell, St. Louis, Missouri

Code:
Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"

# Load "extmod" but omit DGA extension - this must be included as is
#     if you want to change resolution on the fly

  	SubSection "extmod"
   	    Option "omit xfree86-dga"
  	EndSubSection

	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon Mobility M300 (M22)"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Dell 2001FPS"
	Option		"DPMS"
	HorizSync	31-81
	VertRefresh	60
	Modeline "1600x1200" 130.25 1600 1648 1680 1760 1200 1203 1207 1235
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon Mobility M300 (M22)"
	Monitor		"Dell 2001FPS"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1600x1200"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Last edited by mybootorg; 05-02-2006 at 11:50 PM.
 
Old 04-27-2006, 08:39 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
I don't know the technical reason either but here is something you might want to try: Search for [X|x]org.conf* (or any other intelligent combination with a wildcard). That should show all instances of xorg.conf (and, incidentally, xorg.conf.new etc...). Rename them to something different and copy your /etc/xorg.conf to their place(s).

Now your screensaver should hopefully behave properly ...
 
Old 04-27-2006, 11:11 AM   #3
mybootorg
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by JZL240I-U
I don't know the technical reason either but here is something you might want to try: Search for [X|x]org.conf* (or any other intelligent combination with a wildcard). That should show all instances of xorg.conf (and, incidentally, xorg.conf.new etc...). Rename them to something different and copy your /etc/xorg.conf to their place(s).

Now your screensaver should hopefully behave properly ...
I did find another copy of xorg.conf under /usr/xresprobe and replaced it. However, this didn't help me any. Thanks for your kind suggestion nonetheless.

I almost wonder whether my docked laptop is causing the problem. Maybe with the lid closed, the screen is actually still on so Xserver is bringing the screensaver down to the lowest common denominator. It's a Schrondinger's Cat sort of thing really... is the screen really on with the lid closed? Or does it only turn on when I lift the lid? :P
 
Old 04-27-2006, 11:18 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
Quote:
Originally Posted by mybootorg
I did find another copy of xorg.conf under /usr/xresprobe and replaced it. However, this didn't help me any. Thanks for your kind suggestion nonetheless.
Then you missed at least one. There is a template for xorg.conf somewhere on your machine which is copied to /etc/xorg.conf during the initial setup of the system...

Quote:
Originally Posted by mybootorg
I almost wonder whether my docked laptop is causing the problem. Maybe with the lid closed, the screen is actually still on so Xserver is bringing the screensaver down to the lowest common denominator. ...
As a guess, that's not it. The brute force approach would be to delete the 1024x768 resolution from xorg.conf. If this doesn't work you must have a copy somewhere else...
 
Old 04-27-2006, 06:31 PM   #5
mybootorg
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Double checking never hurts. So I went through my system with a fine tooth comb. I used 'find' to find all files having anything to do with xorg. I even piped the result through grep searching for references to 1024x768. Then I searched for references to 1024x768 in all of my files. Nothing of interest.

Here's an interesting new clue though. Today for grins, I was running at 1600x 1200 and decided to change my resolution on the fly to "1024x768" Guess what happened? That's right, it made a smaller sub-window of my desktop in the top left corner of my screen.

Suggests to me that it's not a problem with screensaver resoltuion -- but instead, a problem with changing resolution on the fly. Perhaps the screensavers also try to run at 1024x768 but instead of running in full screen resolution, they end up trapped in the box.
 
Old 05-02-2006, 11:48 PM   #6
mybootorg
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Cool Correct desktop resolution. Incorrect screensaver & lock resolution (SOLVED)

I ****FINALLY**** found a solution to this. The other day on a whim I installed the Gnome Screensavers package. Its pretty basic. Not too many choices - like 3 or 4 choices of screensavers and none of them very interesting. But guess what. They run at the correct resolution and desklock works fine too.

This led me to investigate the problem from a strictly XScreensaver angle and the solution I found made me laugh.... it made me a laugh a big pirate laugh at the pure ridiculousness of it. HAR HARRRR HAR-HAR HARRRR HARRR!

Here's what I found. From the Xscreensaver faq:

Quote:
Originally Posted by Xscreensaver FAQ
This is a bug in the X server, not xscreensaver: the XF86VidModeGetViewPort() function is full of lies, and I don't see any way to work around it.

I believe this only happens on certain laptops, and possibly only on systems that have a docking station or external monitor that runs in a different resolution than the laptop's screen.
Sound familiar? Why yes it does...

Quote:
Originally Posted by Xscreensaver FAQ
There is discussion of this bug in the Red Hat and Debian bug systems; the buck was finally passed upstream to XFree86, where it is bug 421.

The XFree86 developers have closed the bug. As far as I can tell, their reason for this was, "this is an X server bug, but it's pretty hard to fix. Therefore, we are closing it."

So how about that. If you'd like them to actually fix this, you'll have to convince them that it matters, I guess...

In the meantime, you can work around this by editing your .xscreensaver file and setting the "GetViewPortIsFullOfLies" preference to True. That will make xscreensaver always run on the full size of the desktop, regardless of what lies the server tells about the currently-visible area. (This preference was added in version 4.16, May 2004.)
HAR-HAR HARR!
 
Old 05-03-2006, 03:39 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
Gah ... what comes next? I'm glad you could solve this, since I was just preparing a long list of links for you to investigate -- all of which would have helped just nothing.

So, congratulations and the appropriate kudos for your tenacity to solve this -- and for posting the solution here.

Last edited by JZL240I-U; 05-03-2006 at 03:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 04:16 AM
Resolution incorrect on comaq r3000 laptop rcrules Linux - Laptop and Netbook 4 03-03-2005 10:30 AM
Resolution - all values correct Kane2002 Slackware 14 02-14-2005 04:58 PM
screensaver resolution azebuski Linux - Software 0 04-24-2004 06:13 PM
Debian Display resolution incorrect... Mal495 Linux - General 8 11-26-2003 11:44 PM


All times are GMT -5. The time now is 04:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration