LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-29-2002, 08:40 AM   #1
lachlan
Member
 
Registered: Jan 2002
Location: New Zealand
Distribution: Mandrake 9.1,Suse 8.2
Posts: 139

Rep: Reputation: 15
CHMOD and Input/Output errors


Hi.
I have just tried to copy a file,to a 1.4MB floppy,and this was the result.
ERROR: Unable to enter File:/mnt/floppy.You do not have rights to this location.
I also noticed that the /mnt/floppy icon now had a lock on it.
In a terminal I ran chmod various options /mnt/floppy and this was the result.
CHMOD:changing permissions of /mnt/floppy:Input /output error.
When I run MDK 9.0 control centre-system-user I get this response.Cannot lock user lib,file /etc/ptmp or /etc/gtmp exist.I can delete these files temporarily,as when I reboot the files come back again.
Thanks in anticipation.

Lachlan
 
Old 12-29-2002, 09:01 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
It sounds like you don't have the floppy drive mounted. Open up your terminal and then as root type:
mount

This should display what is mounted. If you floppy isn't, then mount it:
mount -t vfat /dev/fd0 /mnt/floppy

Then you should be able to access it. Only as root though. If you want to access it as a normal user you might have to change what's in your /etc/fstab options section. If you have questions on that, post it here and someone can probably help you.

Cool
 
Old 12-30-2002, 04:13 AM   #3
lachlan
Member
 
Registered: Jan 2002
Location: New Zealand
Distribution: Mandrake 9.1,Suse 8.2
Posts: 139

Original Poster
Rep: Reputation: 15
Thanks for the info.I tried to edit /etc/fstab but I screwed up really badly,because when I try to mount /mnt/floppy I get the output:fs type not supported by the kernel.

id: cannot find name for group ID 501
[lachlan@localhost lachlan]$ ls la-/mnt
ls: la-/mnt: No such file or directory
[lachlan@localhost lachlan]$ ls -la /mnt
total 24
drwxr-xr-x 6 root 0 4096 Nov 21 11:00 ./
drwxr-xr-x 19 root 0 4096 Dec 30 21:14 ../
drwxr-xr-x 2 root 0 4096 Nov 21 10:27 cdrom/
drwxr-xr-x 2 root 0 4096 Nov 21 11:00 disk/
drwxrwx--- 2 lachlan 501 4096 Dec 29 09:20 floppy/
drwxrwxrwx 9 root 0 4096 Jan 1 1970 windows/
[lachlan@localhost lachlan]$

/dev/hdb5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom dev=/dev/cdrom,fs=auto,codepage=850,noauto,iocharset=iso8859-15,nosuid,ro,umask=0,
none /mnt/floppy dev=/dev/fd0,fs=auto,--,codepage=850,sync,iocharset=iso8859-15,unmask=0,
/dev/hda1 /mnt/windows vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb7 /usr ext3 defaults 1 2
/dev/hdb3 swap swap defaults 0 0
/dev/hdb6 swap swap defaults 0 0
~
~
~
~
~
~
~
~
~
~
~
~
"/etc/fstab" 9L, 470C 4,1 All

Regards

Lachlan
 
Old 12-30-2002, 05:11 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
It's trying to guess the filesystem. The "auto" option which is in your /etc/fstab entry will do it's best at guessing. I tend to use mainly floppies formatted with fat32 filesystems. So I have my entry using the filesystem vfat.

Here's my entry, you don't have to use this, but it might give you some ideas (man mount and man fstab will explain things about this for you):
Code:
/dev/fd0         /mnt/floppy      vfat        noauto,owner              0   0
Basically, it will automatically assume the filesystem is vfat, then mount it with the options noauto,owner

If you use a lot of floppies that are of different filesystems, you might wanna leave the "auto" in your entry in /etc/fstab.

Also, you might wanna check and make sure your distro has support for vfat, if you aren't sure I believe it's:
cat /proc/filesystems

HTH

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KNOPPIX 4.02 Input/Output Errors nomind Linux - Newbie 2 11-03-2005 11:17 PM
input/output errors, volume, and flashdrives oh my! jloaf Linux - General 1 10-22-2003 07:19 AM
Input/Output errors on files Poetics Slackware 4 08-25-2003 06:57 PM
Input/Output errors on Mandrake 9.1 exalik Linux - Distributions 2 08-18-2003 05:20 PM
overcoming input/output errors heiseltc Linux - General 0 02-26-2003 01:29 PM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration