LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-25-2005, 10:23 AM   #1
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Changing terminal font size


Hi all,
I boot into text mode rather than straight into X, and since I've reinstalled Slack 10 the font size has been _huge_. I know it wasn't so in Slack 9, but obviously that system is gone so I can't compare config files and such.

To help control font size when X is running, I've edited /etc/X11/xdm/Xservers and added "-dpi 96 vt7" to the line reading
:0 local /usr/X11R6/bin/X

but that's not going to help things before X starts. Does anyone have an idea of what I can do in this situation?

(...as an extra question...what's the "vt7" doing there??)

Thanks!
 
Old 05-25-2005, 10:37 AM   #2
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
At a guess, I'd say you've lost framebuffer support. Either you didn't put it into your kernel, or you didn't put it into your bootloader options.
 
Old 05-25-2005, 12:14 PM   #3
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
Hmm...if it could be a bootloader problem, I did keep my old lilo.conf from the previous installation:

Old:
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact        # faster, but won't work on all systems.
prompt
timeout = 300
# VESA framebuffer console @ 1024x768x256
vga = 773
## Whole bunch of vga options commented out here...###

image = /boot/vmlinuz
  root = /dev/hda1
  label = Slackware
  append="devfs=mount hdd=ide-scsi"
  read-only # Non-UMSDOS filesystems should be mounted read-only for checking
New:
Code:
boot=/dev/hda
prompt
timeout = 300
vga=normal

image=/boot/vmlinuz
  root=/dev/hda1
  append="hdc=ide-scsi"
  label=Slackware
  read-only
possibly the vga=773 vs vga=normal?
 
Old 05-26-2005, 02:43 AM   #4
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
Yep - the 773 is a cue to tell your framebuffer to adopt a 1024x768 resolution, which is much higher than the default. Change the setting, and you should be back to normal on the console front
 
Old 05-26-2005, 08:17 AM   #5
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Original Poster
Rep: Reputation: 30
W00t. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change font size in terminal window homerjpbody Linux - Newbie 3 08-08-2008 09:26 PM
init 3 and terminal font size ninjaz Red Hat 3 10-03-2005 04:35 PM
changing the font size prasanta Linux - Newbie 1 04-20-2005 06:49 AM
how could i make my font size smaller in terminal Paxmaster Linux - Software 3 02-05-2005 08:43 PM
Changing font size kamransoomro84 Programming 2 06-27-2004 10:54 PM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration