LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-27-2001, 03:59 PM   #1
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Rep: Reputation: 30
Question Changing file ownership on Fat32 drives


Hi Everybody!

In my System, there is an old FAT32-formatted hdd running for filesharing-use. It is mounted vfat defaults 1 1.
I tried changing the ownership of the files on that disk with chown and -even as root- got the error message operation not permitted

What Do I have to change, so the files belong to nobody and can easilier be rw-shared with samba???
 
Old 07-27-2001, 04:30 PM   #2
isajera
Senior Member
 
Registered: Jun 2001
Location: San Antonio, TX
Distribution: distro? what's a distro?
Posts: 1,635

Rep: Reputation: 45
fat 32 files don't have permissions... that's a linux/unix/bsd thing. when you write a file to a fat32 partition from windows, linux treats the file as a fat32 file, not linux file... thus, no permissions.
 
Old 07-27-2001, 04:55 PM   #3
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Original Poster
Rep: Reputation: 30
true. still- If I want to have rw-access via Samba I need to set the guest account in smb.conf to root. And I guess thats not the way to do it.

Any Suggestions except reformatting in any Unix FS?
 
Old 07-27-2001, 05:06 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
you gotta change /etc/fstab on the remote machine. it's not a samba thing (took me ages to find that out!). My fstab line says:

/dev/hda1 /windows vfat user,umask=000 0 0
/dev/hdb1 /mp3 vfat umask=000 0 0

This is WRONG tho!!! and i don't quite know what the EXACT right options are, the umask=000 makes all files writeable etc.. to everyone, but i still have various problems writing to them from win98...

Can someone define the definitive options required for this? please?

chris
xxxx
 
Old 07-28-2001, 05:12 PM   #5
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Original Poster
Rep: Reputation: 30
Thanx for the tip. It worked fine for me. although I only set umask=111 so the executable flag is not set.

my line reads like this:

/dev/hdg1 /windows/C rw,nouser,auto,umask=111 0 0

probably the drive wasn't mounted rw by default?

What kind of problems are you experiencing??

Last edited by Steave; 07-28-2001 at 05:16 PM.
 
Old 07-29-2001, 04:23 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
I get problems such as when i untar an archive onto a fat32 drive, i get lots of permision denieds, and cannot create link problems (i think that's what they were...). Pretty vague.... I'll change my settings to your ones, and see if it's any better...

Chris
xxxx
 
Old 07-30-2001, 11:32 AM   #7
Steave
Member
 
Registered: Jul 2001
Location: Braunschweig, Germany
Distribution: Suse 7.2
Posts: 184

Original Poster
Rep: Reputation: 30
Hi There!

I thought about it a bit and probably this is the solution:

Since FAT32 doesn't support ownership of files tar will have a problem setting the correct properties. You should get the same errors using chmod or chown.

So: Don't worry about the errors. If those are important files you should be aware that any user can access and modify them!
 
Old 07-30-2001, 04:14 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
hehe, thanks. I'll try and remember that all otehr others users can do that...!

Other users, however in my case is erm... my girlfriend sometimes, to check her email!

chris
xxxx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't change ownership on a Fat32 partition kt8993 Linux - Security 2 01-09-2005 10:21 AM
changing file ownership /dev/dsp (doesnt work..) icehenge Linux - General 8 03-12-2004 08:48 PM
problem changing file permissions on fat32 partition coolamit78 Linux - Software 4 01-18-2004 01:44 PM
changing ownership of downloaded file ergo_sum Linux - Newbie 2 09-19-2003 07:58 PM
fstab, mounting a fat32 partition, need help w/ ownership and all that mackstann Linux - General 2 10-15-2001 02:37 PM


All times are GMT -5. The time now is 08:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration