LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-15-2007, 09:25 PM   #1
Virtuality
Member
 
Registered: Jan 2007
Distribution: Debian Etch
Posts: 193

Rep: Reputation: 30
Changing Default Audio Device - I have 2 sound cards


Hi,

I have my headphones in one sound card and 5.1 speakers in the other.

When I run :

Code:
speaker-test -Dplug:surround51 -c6 -twav
It comes through the headphones (onboard sound card).

I want it to come through my speakers but I don't know how to make it.

Same with totem-xine; it plays through onboard and not my one with speakers in it.

Where do I change this?

XMMS plays through speakers because it has the option to change the device.

Also even if the test succeeds how do I make XMMS use 5.1 sound?
 
Old 12-15-2007, 09:34 PM   #2
Virtuality
Member
 
Registered: Jan 2007
Distribution: Debian Etch
Posts: 193

Original Poster
Rep: Reputation: 30
Well I figured out 5.1 sound, you just make a file on your home directory called '.asoundrc' with:

(I did NOT write this myself, it's from ubuntu forums)

Code:
pcm.dmix51 {
	type dmix
	ipc_key 1024
	ipc_key_add_uid false
	ipc_perm 0666 
	slave {
		pcm "hw:1,0"
		channels 6
		period_time 0
		period_size 1024
		buffer_size 8192
		rate 44100
	}
}

ctl.dmix51 {
	type hw
	card 1
}

pcm.stereo {
	type plug
	slave.pcm "dmix51"
	ttable.0.0 1
	ttable.1.1 1
}

pcm.!default {
	type route
	slave.pcm "dmix51"
	slave.channels 6
	ttable.0.0 1
	ttable.1.1 1
	ttable.0.2 1
	ttable.1.3 1
	ttable.0.4 1
	ttable.1.4 1
	ttable.0.5 1
	ttable.1.5 1
}

pcm.duplicate {
	type plug
	slave.pcm "dmix51"
	slave.channels 6
	route_policy duplicate
}
Then go to XMMS, click plugins and hit CTRL+P just before you select alsa mixer and it works.



But how do I change the default device totem uses?




To think, I don't even have a proper driver for this sound card yet it sounds better than it does on windows...

Last edited by Virtuality; 12-15-2007 at 09:39 PM.
 
Old 12-15-2007, 10:28 PM   #3
kzutter
Member
 
Registered: Nov 2007
Location: Carson City, NV USA
Distribution: Various, but always Debian based
Posts: 70

Rep: Reputation: 15
I have 2 sound cards, one built-in on my MB and one PCI card.
I only wanted to use the PCI card one, so I disabled the onboard sound in my MB's BIOS.

Unless you need both cards running, this maybe a solution for you, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux using wrong default audio device - it's using TV Card Virtuality Linux - Software 1 12-14-2007 10:06 AM
How can I set a newly installed soundcard as the default audio device? Crushing Belial Linux - Hardware 2 12-23-2005 09:55 PM
How to pipe the default audio h/w device directly to hw:0,2 Erin Linux - Software 3 04-16-2005 11:55 AM
Two sound cards: Which one is default? dominik81 Linux - Hardware 2 04-10-2005 06:37 PM
change default audio device (debian woody) zhynn Debian 3 07-04-2003 04:35 PM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration