LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-17-2002, 03:18 AM   #1
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Rep: Reputation: 30
changed runlevel and no boot


i changed my default runlevel from 3 to 4, 4 being graphical logon, and after i enter my username and password, the thing dowsn't boot to my windowmanager. xfce is default, i tryed going into gnome but no dice. the logon is a gnome graphical logon, any ideas?

id like to boot in graphical mode can anyone tell me how, if not how can i get to the command prompt to edit my inittab file?
 
Old 08-17-2002, 03:43 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Using anyone of the F1-F6 keys along with a CTRL + ALT will give you a terminal.

Then you can use whatever your favorite text editor is, lets say vi:
vi /etc/inittab
Should open it.

Try 5 instead? Maybe 5 will work for you better than run level 4. Just an idea, I really have no idea though.

COol
 
Old 08-17-2002, 03:55 AM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Any type of errors given ?? When your signing in, is it graphical or is it at a command ?

And if you are using Slack, the correct runlevel for graphical is 4.
 
Old 08-17-2002, 04:00 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Oh, thanks tricky.
 
Old 08-17-2002, 11:23 PM   #5
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
no errors, and it's graphical. when i installed i made it boot to command because of the xwindow issues i knew id have, but now since i only use my box in graphical mode i decided to change to a graphical boot, to save time. when the password box pops up i enter my user and password and hit enter. the thing goes black then pops the user and password box up again. i want to boot to xfce and i am running slack. no errors are given that i can see. is there a file i could browse to see if somehing crashed?
 
Old 08-17-2002, 11:56 PM   #6
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
I know it might be a pain in the .... hole to startx from a console and see GNOME desktop fr instance, to see something new you have to edit .xinitrc file. What if your preferences change often you have to edit it over and over again, may I suggest a little perl script that allows you to start X with any Window Manager of your choice with little or no modification to this perl script. Please welcome sdx11
It is small and configurable (plain perl). I edited it to include -nolisten tcp option to startx command as well as added the ability to use my favorite fluxbox (by default it comes with ability to boot into GNOME, KDE, Afterstep, Enlightenment, Black Box, Window Maker, xfce, IceWM, Ude, SawMill, Fvwm2. And it only takes to login to console and run sdx -your favorite wm. You can also add any programs tthat you want to start along with window manager or desktop environment.
 
Old 08-18-2002, 03:19 AM   #7
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
it seems as though this program your recommending just changes the default window manager then the user does startx and the thing starts. im looking to shave milliseconds off my boot time by not having to startx. i want it to boot automatically. is what i said about your prog correct neo?
 
Old 08-18-2002, 12:23 PM   #8
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
Yep pretty much, sorry I didn't get the initial question, but I don't think these milliseconds are significant, look after all the services are initialized the system is going into runlevel defined in /etc/inittab, if it is 4 (slack's X, right?) then system starts gdm/kdm/xdm (whichever suits your setup better), it looks for an available tty and starts desktop manager, you're presented with login screen (unless you want it to boot into X without even asking you for password, I know in Mandy you can do so somewwhere in login manager section of Control Center, or by setting an appropriate system profile - honestly Ihave no clue how to do so, at least I was looking for command line versions, GUI is too bloated for me, and I have no clue what tools are invoked when you set your security level to as low as possible). Then it does authantication via pam modules and /etc/passwd, /etc/shadow, it looks for a DISPLAY variable and invokes startx. In the case of runlevel 3 you are presented with login screen, you login -> authantication -> you type startx. I don't know which one is faster - going through GUI or typing sdx -fb (or !s which is the last command executed starting with letter s and it is almost always sdx for me, unless I don't boot into X to do some kernel compilation and quit out).

Last edited by neo77777; 08-18-2002 at 12:25 PM.
 
Old 08-18-2002, 10:51 PM   #9
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Maybe the command xwmconfig is what you're looking for.
 
Old 08-19-2002, 01:12 AM   #10
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
i changed my default runlevel from 3 to 4, 4 being graphical logon, and after i enter my username and password, the thing doesn't boot to my windowmanager. xfce is default, i tryed going into gnome but no dice. the logon is a gnome graphical logon.
xwmconfig doesn't solve my problem.
 
Old 08-19-2002, 06:29 PM   #11
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
when i did ctrl+alt+ various f#keys, i was changed to another terminal but could not enter anything into it. all it did was display a blinking dash symbol. still cannot boot into gui or command yet, any other ideas?
 
Old 08-20-2002, 11:31 PM   #12
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
would it work if i booted from a boot disk?... i dont have a linux boot disk.
 
Old 08-21-2002, 12:03 AM   #13
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
I have zipslack installed and when I run X window I can get a terminal by pressing ctrl+alt+f6.
 
Old 08-21-2002, 03:21 AM   #14
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
ive tried using all f numbers. ctrl+alt+f1 - f12, none work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change runlevel on boot? Randall Slack Slackware 6 06-30-2005 04:30 PM
can't boot into runlevel 1 Eunsuk Kang Linux - General 1 09-30-2004 09:12 AM
changed default runlevel from 3 to 4 in inittab- now I'm stuck in a loop Earl Parker II Linux - Newbie 15 07-12-2004 09:37 AM
How to boot in runlevel 3 Dillutedmind Linux - General 3 03-23-2003 05:23 PM
I cannot boot, something about runlevel Dekem Linux - Newbie 1 08-04-2002 10:16 PM


All times are GMT -5. The time now is 06:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration