LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-30-2003, 06:55 PM   #1
CrazyHorse
LQ Newbie
 
Registered: Jul 2003
Location: NZ
Distribution: Ubuntu
Posts: 22

Rep: Reputation: 15
CD's play but no other sound


I have come quite far in my quest for audio in Linux and I hope that perhaps my journey is nearing an end.
After a solid week of trawling through Linux forums of some form or another I have come here to post my unique problem.

Firstly my Setup:

MOBO: Gigabyte GA-VRX
onboard sound chip: Via VT8233A Ac97

I run 'Yoper' Linux and it has ALSA built into.
All that is required is that you 'unlock' it and modify
your modules.conf file to contain the lines pertinent to your
particular sound hardware.

My problem is that I can get standard CD's (ie non mp3) to play quite happily with XMMS, but I cannot get mp3's, wavs, ogg or even cda files on the hard drive to play.

So it would seem that programs such as XMMS can access
the sound chip but not the hard drive. plausible?

Also here is my modules.conf file:

alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-via8223A
# module options should go here
options parm: index int array (min = 1, max = 8), description "Index value for VIA 82xx bridge."
options parm: id string array (min = 1, max = 8), description "ID string for VIA 82xx bridge."
options parm: enable int array (min = 1, max = 8), description "Enable audio part of VIA 82xx bridge."
options parm: mpu_port long array (min = 1, max = 8), description "MPU-401 port."
options parm: ac97_clock long array (min = 1, max = 8), description "AC'97 codec clock (default 48000Hz)."

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss



I would greatly appreciate any help.
 
Old 07-31-2003, 03:52 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
This is probably a silly question, but have you checked all your mixer settings? If you use KDE, try kmix, or maybe aumix. See if the CD level is up, and all others are down. If so, raise all the other sliders.
 
Old 07-31-2003, 07:09 AM   #3
CrazyHorse
LQ Newbie
 
Registered: Jul 2003
Location: NZ
Distribution: Ubuntu
Posts: 22

Original Poster
Rep: Reputation: 15
Mixer settings are ok

A reply!! wahooo.

I have played extensively with the mixer settings and they seem fine.
I should really say now that I have another thread on the homepage of my distro 'Yoper' but because of the rule here that you cant include a URL unless you've posted 5 messages, it wasnt included in the first message.
I started a thread here because the Yoper forum doesnt get much traffic and I have spent the last week basically posting replies to myself as I figured things out.
If you were interested in seeing that forum you could google 'yoper' to get the homepage. My thread is in the free support forum under the same user name 'CrazyHorse'.
That thread gives a good background to my problem.

Anyway thanks for replying and I hope you (or anyone else)
has some more options for me to try.

Ta.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't play CD's Valhalla Linux - Software 2 03-06-2005 01:20 PM
Sound Card won't play cd's javiergt Linux - Hardware 10 08-19-2004 06:22 PM
how come i cant play my cd's???? blind958 Mandriva 3 07-16-2004 03:34 PM
CD's play no sound- other sounds are fine turls Linux - Hardware 10 01-06-2004 02:45 PM
help me play cd's dynamo593 Linux - General 0 12-23-2001 02:49 PM


All times are GMT -5. The time now is 07:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration