LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-26-2005, 10:59 PM   #1
bendeco13
Member
 
Registered: Oct 2004
Distribution: Fedora 7
Posts: 232

Rep: Reputation: 30
Capitalize folders with less than 4 characters


When I try and create or name a folder to 3 characters or less and try to capitalize any of the characters, all of them remain lower cased.
This is a really annoying.
I only tried this on folders in konqueror.
I think that this problem has something to do with the file extensions (considering that most are 3 characters or less), but I thought that file extensions weren't important in Linux.

For example:
creating the folder "RA"
gets renamed to "ra"

Has anyone had this problem as well?
Does anyone know of a way around this?

Thanks in advance
Bendeco
 
Old 09-26-2005, 11:05 PM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
have you tried making them from the command line? you should be able to create a directory in uppercase with even one character.
 
Old 09-26-2005, 11:07 PM   #3
bendeco13
Member
 
Registered: Oct 2004
Distribution: Fedora 7
Posts: 232

Original Poster
Rep: Reputation: 30
Yes, I just tried this...
But it doesn't work either.
Konqueror still reads it as lower case, and when I 'ls' it is also listed as lower case.

But thanks for the suggestion.
 
Old 09-27-2005, 08:00 AM   #4
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
I think that this problem has something to do with the file extensions (considering that most are 3 characters or less), but I thought that file extensions weren't important in Linux.
I think you're right in the case of vfat mounted partitions. It refuses to make folder names all caps unless the folder name is over eight characters long. I think it's just a vfat odd ball thingy.

1. Is this happening on a vfat mounted partition?
2. Can you use ext3 instead?
 
Old 09-27-2005, 07:57 PM   #5
Vgui
Member
 
Registered: Apr 2005
Location: Canada
Distribution: Slackware
Posts: 496

Rep: Reputation: 31
Yep, this is a FAT16 / FAT32 thing. These two are not case sensitive file systems, and so store as lower case all the time. A folder called TesTinG is the exact same as testiNg, on FAT. So, any upper / lower case changes you make won't be saved. That's how it is with junky case insensitive filesystems
 
Old 09-28-2005, 03:26 PM   #6
bendeco13
Member
 
Registered: Oct 2004
Distribution: Fedora 7
Posts: 232

Original Poster
Rep: Reputation: 30
Thanks alot for all of your replies...

I AM using a vfat partition, but it's a spare harddrive that I have had for a long time and haven't been able to back up the data to reformat it. I'm just glad it's not a Linux problem.

Does the NTFS format behave in this same manner?

Thanks again
Bendeco
 
Old 09-28-2005, 03:50 PM   #7
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
Does the NTFS format behave in this same manner?
I don't think so but it's a step in the wrong direction.
You would have to enable ntfs support on your linux box which can be a pain.
 
Old 09-28-2005, 06:22 PM   #8
bendeco13
Member
 
Registered: Oct 2004
Distribution: Fedora 7
Posts: 232

Original Poster
Rep: Reputation: 30
Quote:
I don't think so but it's a step in the wrong direction.
You would have to enable ntfs support on your linux box which can be a pain.
Yea, I'm with ya there, configuring the Kernel, etc.
but I'm trying to keep this harddrive compatible with windows.
I guess I'll just have to deal with the character problem or go through the painful process of setting up support for NTFS.
I read somewhere that the Kernel was eventually going to have full (default) support for NTFS partitions, but I may be wrong.
Oh well...

Thanks for the info,
Bendeco
 
Old 09-28-2005, 10:14 PM   #9
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
at least if you switch to NTFS you'll fix your problem: you won't have to worry about upper or lower case anymore, because you won't be able to write anything.

fwiw, i can make directories with uppercase characters on my samba mounted fat32 filesystems. not sure about all the weirdnesses of windows 8+3 stuff, etc. to know why, but i just wanted to put out there for you that it is possible to have fat32 and make uppercase directory names.
 
Old 10-07-2005, 05:04 AM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think that there are mount options for fat32 that deal with case sensitivity. Perhaps the problem has to do with how the drive is mounted. If you use the "utf8" option for instance, you should be able to have folders in Russion if you wanted to.

Please refer to the mount and fstab man pages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accented characters in C Orkie Programming 2 05-17-2005 12:50 PM
few characters like 'i' not printing somasekhar Linux - Newbie 2 12-17-2004 10:25 AM
* should represent any characters suchi_s Programming 6 07-31-2004 03:50 PM
Weird Characters LQtoto Linux - Software 2 07-01-2004 05:10 PM
Missing X characters ak47fred Linux - General 0 05-16-2001 05:02 AM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration