Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 11-12-2008, 10:32 AM   #1
LQ Newbie
Registered: Oct 2008
Posts: 4

Rep: Reputation: 0
cant start gnome? startx (gnome) doesn't work?

I can't start my GUI for gnome. I am running a virtual machine(vmware) to run ubuntu 8.04. I am able to log in to the command line, but it is still very inconvenient. I tried startx, startx gnome, and several other things I found on the internet, but nothing I try works. I am logged on. It asks for my user login and then my password. It never starts the GUI.

When I type startx (gnome) it shows a rectangle of colored vertical lines in the upper left side of my screen. Then a square of tannish dots fill a big square over where my command promp was. It has an x in the middle and I can move the x with my mouse. It's a screen alignment tool, maybe?

I have no idea whats wrong.
Please HELP!

23:43:45 UTC 2008 i686
Build Date: 13 June 2008 01:08:21AM

Before reporting problems, check to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notics (II) informational, (WW) warning (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 5 04:52:03 2008
(==) Using config file: "/etc/X11/xorg.cong"
(II) Module "ramdac" already built-in
expecting keysym, got XF86KbdLightOnOff: line 70 of pc
expecting keysym, got XF86KbdBrightnessDown: line 71 of pc
expecting keysym, got XF86KbdBrightnessUp: line 72 of pc
expecting keysym, got XF86KbdLightOnOff: line 70 of pc
expecting keysym, got XF86KbdBrightnessDown: line 71 of pc
expecting keysym, got XF86KbdBrightnessUp: line 72 of pc
[config/hal] couldn't initialise context: (null) ((null))

waiting for X server to shut down FreeFontPath: FPE "/usr/share/fonts/X11/misc"
refcount is 2, should be 1; fixing

name@name-desktop:/usr/share/fonts/X11& _
Old 11-12-2008, 11:35 AM   #2
Senior Member
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled

you need to reconfigure xserver-xorg apparently

What is this -->"/etc/X11/xorg.cong"


#sudo dpkg-reconfigure --help
Old 11-12-2008, 12:10 PM   #3
Senior Member
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
Another command to try and set up your Xorg file: "sudo dpkg-reconfigure xserver-xorg".

As amani asked above, please post your current xorg.conf before running the above command.
Old 11-12-2008, 12:12 PM   #4
Senior Member
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,170

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
What you're seeing is the "default" Xinit screen, presented when no valid xinitrc was found by startx.

Since you're running Ubuntu, check that the scripts in /etc/X11/Xsession.d/ are correct and that the symbolic links in /etc/alternatives/x-session-manager are valid.

Did you create your virtual system by installing Ubuntu, or are you trying to use a system that was already on one of your partitions? If it's the latter, perhaps the device names in your virtual system differ from the ones used on the stand-alone installation. If so, you might be able to set them properly in your virtual manager.
Old 11-13-2008, 10:27 AM   #5
LQ Newbie
Registered: Oct 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I am running windows vista home edition. I used VMware to start up and run ubuntu.
I shut down ubuntu then closed vmware all in the same order I did it several times before.
When I started up ubunu again it took me straight to the command line without gnome.
so basically I can view my files and have access to everything, but I don't have any gui at all.

this is my xorg.conf file that you wanted to see

# xorg.cong (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuation tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "VMware Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "VMware Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"

Section "Device"
Identifier "VMware SVGA"
Driver "vmware"

Section "Screen"
Identifier "Default Screen"
Device "VMware SVGA"
Monitor "vmware"
# Don't specify DefaultColorDepth unless you know what you're
# doing. It will override the driver's preferences which can
# cause the X server not to run if the host doesn't support the
# depth.
Subsection "Display"
" VGA mode: better left untouched
Depth 4
Modes "640x480"
ViewPort 0 0
Subsection "Display"
Depth 8
Modes "1024x768"
ViewPort 0 0
Subsection "Display"
Depth 15
Modes "1024x768"
ViewPort 0 0
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
Subsection "Display"
Depth 24
Modes "1024x768"
ViewPort 0 0

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "VMware Keyboard" "CoreKeyboard"
InputDevice "VMware Mouse" "CorePointer"
Section "Monitor"
Identifier "vmware"
VendorName "VMware, Inc"
HorizSync 1-10000
VertRefresh 1-10000

Last edited by beam2008; 11-13-2008 at 10:32 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashing Gnome Login And Missing Gnome Panels, Gnome is borked! openSuse 10.2 Perps SUSE / openSUSE 1 03-17-2008 06:22 PM
gnome-panel won't start after upgrade to GNOME 2.6 computergeek84 Debian 5 08-12-2007 02:37 PM
I want gnome! My gnome doesnt start anymore! :( maginotjr Slackware 2 07-09-2005 04:06 PM
After upgrading to Gnome 2.8, Gnome Panel doesn't work Xavius Linux - Software 0 12-27-2004 03:17 PM
How to startx into KDE instead of GNOME? e11 Linux - Newbie 6 10-23-2004 06:42 PM

All times are GMT -5. The time now is 02:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration