LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Can't source a linked directory from another user (http://www.linuxquestions.org/questions/linux-general-1/cant-source-a-linked-directory-from-another-user-749345/)

Leo Simon 08-21-2009 01:55 PM

Can't source a linked directory from another user
 
I'm running Ubuntu hardy on two machines. On one of them, I can't source a file from another user's directory, even though the file is set up as 777. On my other machine, I can source the file with the standard 644 permissions. The two installations should be identical, but I must have screwed up something on the first one. Any suggestions would be appreciated!

hasienda 08-22-2009 05:54 PM

I don't know, why you'd like to use someones files from within his/her home directory. I always resort to making all homes 700 - really private.

I consider it good style to create a dedicated common place for files to share like /pub owned by a common users group with suitable permissions, set-group-id and even sticky-bit set.

If you absolutely need/insist to carry on with your home directory permissions: You've made sure, that the 777 is not the fault itself, haven't you? Not only that you might not need execute-permission *), it may even make some checks for strict/suitable file permissions fail ...

Just my 2 cents. :-)

*) ... and you shouldn't make more files executable that the absolute minimum (typically governed by your Ubuntu's default installation, if there is not a current, urging need to do so. Use dpkg-statoverwrite to make permanent, reproduce-able changes to local dir/file permission settings, assuming you have this call on your systems (works on Debian, the base of Ubuntu).

If this doesn't help too much, I' ll require to know more about what file you're trying to source for what purpose to get a better clue. For now I wish you good luck.

Leo Simon 08-22-2009 06:17 PM

Thanks! It's my home machine so I'm not worried about users using other users' stuff. It turns out that indeed all home directories *were* 700, which was where all my problems came from. Don't know how that happened, but I reset them to 644 and I'm happy!

hasienda 08-22-2009 06:32 PM

Quote:

Originally Posted by Leo Simon (Post 3653944)
Thanks!

Great! Glad I could help. :-)
BTW, consider tagging a resolved issue as "solved" and to use the "Thanks"-function to honor LQs members for good advise given. It simply feels sooo good, that I makes me looking into more zero-reply threads ...

Leo Simon 08-25-2009 01:48 AM

Done!


All times are GMT -5. The time now is 08:17 PM.