LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Cannot to an external SMTP e-mail server (http://www.linuxquestions.org/questions/linux-general-1/cannot-to-an-external-smtp-e-mail-server-895311/)

igadoter 08-03-2011 09:09 AM

Cannot to an external SMTP e-mail server
 
Hi,
I have an e-mail box account on an IMAP/SMTP external server. There is no problem with incoming mails - but I am unable to send e-mail using this external SMTP server. K-mail is unable to contact, while Seamonky e-mail client is stuck trying to contact.

It seems for me that all settings for email clients are done well. I am thinking about two possibilities: 1) I have to run a service on my computer 2) my Linksys wireless router is set up to not allow outgoing SMTP connections.

Have you any idea what's going on?

acid_kewpie 08-03-2011 10:52 AM

well to troubleshoot it I would look at using telnet to try to hit port 25 on whatever host you are using. What is the outbound SMTP? In those situations your ISP might be insisting that you use their own relay, assuming they have one, so that can be something to check.

igadoter 08-03-2011 01:21 PM

I tried this
Code:

# telnet  mailhost 25
Trying xx.xx.1.33...
telnet: connect to address xx.xx.1.33: Connection timed out
Trying xx.xx.250.2...
telnet: connect to address xx.xx.250.2: Connection timed out
# telnet mailhost 465
Trying xx.xx.250.2...
telnet: connect to address xx.xx.250.2: Connection refused
Trying xx.xx.1.33...
telnet: connect to address xx.xx.1.33: Connection refused
~# telnet mailhost 443
Trying xx.xx.1.33...
Connected to mailhost
Escape character is '^]'.
Connection closed by foreign host.

Why 443? A web mail service (on the same server) works on the 443 port.

acid_kewpie 08-03-2011 01:24 PM

OK, so looks like I might be right... check with your ISP.

igadoter 08-03-2011 02:54 PM

Yes, but what about my home wireless router. Is it possible it has a some kind of a protection which follows
to not allow outgoing SMTP connection? There is a way I can check this?

minnarky 08-03-2011 02:58 PM

Try changing your outgoing smtp port on your email client to 587.

Many isp's now block port 25 unless it's going to THEIR email server. But your server will probably accept traffic on 587.

igadoter 08-03-2011 03:27 PM

There is something on 587 but not SMTP - trying to connect causes 'unrecognized protocol'

igadoter 08-03-2011 03:50 PM

Funny thing is that I sent email using sendmail - but the delivery took about 1 h :).

acid_kewpie 08-03-2011 04:07 PM

You could use a tool like lft to see how far your tcp packet goes before being nuked.

igadoter 08-03-2011 07:24 PM

@minnarky
Thanks. Seems that I missed some settings. Now the 587 port is working.


All times are GMT -5. The time now is 05:01 AM.