LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-10-2004, 02:32 PM   #1
spid
LQ Newbie
 
Registered: Jan 2004
Posts: 8

Rep: Reputation: 0
Cannot open X session


Dell Inspiron 8200 - Mandrake 9.2 - XIG Summit Graphic Driver. Setup working fine for a few months.

1. Last modification: yesterday night upgrade XCdroast
2. This morning: can't open an X session either in KDE (default) or GNOME. Load on splash screen in order to enter username and password - enter both and I come back to the splash screen.
3. On consol : username and password recognized.
4. Reinstalled Graphic Driver (in case).
5. startkde gives :
xset: unable to open display ""
xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ''
xmodmap: unable to open display ''
xmodmap: unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
kdeinit: Aborting. $DISPLAY not set.
Warning: connect() failed: : No such file or directory
kdmserver: cannot connect to X server
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't connect kdeinit!
startkde: Running shutdown scripts...
startkde: Done.

Looked on Google have seen same messages but no solution.

Some help would be appreciated. Thanks.
 
Old 01-10-2004, 02:45 PM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
startkde won't work. Use
startx
from text mode.
 
Old 01-28-2004, 11:35 AM   #3
Frankeli-Dokeli
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
I have the same problem and I also updated xcdroast right before that happened. It was only one of the numerous updates I did though, so I'm not sure if it's THE one...

"startx" won't work either, I still get the "$DISPLAY not set" error message, amongst others.

I tried reconfiguring with xf86config to no avail...

Please help me get back into my system!

Any help is welcome!!!
 
Old 01-28-2004, 01:58 PM   #4
spid
LQ Newbie
 
Registered: Jan 2004
Posts: 8

Original Poster
Rep: Reputation: 0
In my case permissions on /etc/X11/Xsession were changed. I had to change them.

Goog luck!
 
Old 01-28-2004, 03:14 PM   #5
Frankeli-Dokeli
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
Thank you spid, I will check that out...

May I ask what the correct permissions are?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Open My X Session T-u-N-i-X Linux - Software 4 08-02-2005 04:31 PM
could not open session bigcc Linux - General 7 04-15-2004 08:40 AM
could not open session Frankie Linux - Newbie 1 12-01-2003 10:47 AM
How to open several Session X bart59 Linux - General 13 05-23-2003 01:45 PM
could not open session czech Linux - General 0 08-29-2002 07:49 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration