LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-27-2005, 11:35 AM   #1
pafinator11
Member
 
Registered: Jul 2005
Location: Massachusetts
Distribution: Debian Lenny, FreeBSD
Posts: 89

Rep: Reputation: 15
cannot install rpms, use apt-get/yum/up2date


Yesterday I did an up2date and it installed fine then a little bit later I updated all my packages using apt-get. I am in Fedora Core 3 and now I am attempting to install adobe reader and this is what I get:
rpm -Uvh '/home/paul/AdobeReader_enu-7.0.0-2.i386.rpm'
rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages database in /var/lib/rpm

I cannot do anything that has to do with rpm files. Any ideas?
Thanks in advance,
Paul
 
Old 07-27-2005, 11:40 AM   #2
pafinator11
Member
 
Registered: Jul 2005
Location: Massachusetts
Distribution: Debian Lenny, FreeBSD
Posts: 89

Original Poster
Rep: Reputation: 15
nevermind i figured it out. I fixed it using the following command:
rm /var/lib/rpm/__* && rpm --rebuilddb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO's for the front page.... apt, up2date, synaptic, yum, yumex t3gah LQ Suggestions & Feedback 2 03-21-2005 07:52 AM
yum/apt/up2date blending - problem of synchronisation? captain-cat Linux - Newbie 1 07-07-2004 09:42 AM
using yum to install rpms - how? dingo_aus Linux - Software 9 07-01-2004 09:50 PM
Can i install Kernel 2.6.3 via Yum / Apt? Anzxio Fedora 5 03-09-2004 10:22 AM
RPMs upgrade:up32date,apt-get,redcarpet, yum ? Biased turkey Fedora 1 02-02-2004 03:34 PM


All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration