LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-24-2003, 06:03 PM   #1
sstudley
LQ Newbie
 
Registered: Feb 2003
Location: Tampa, FL
Distribution: Suse9.0, RH 8
Posts: 3

Rep: Reputation: 0
Cannot change dir permissions from root


Using an 8 gig fat32 partion formated in WinXP, data sharing and being ftp'ed over the internal net to load different distos on various boxes.
In suse 81 as root, no problems, as a user cannot get a look at anything.
In the shell tried to chmod the dir /media/g to an acceptable set.
It comes up with an error, that I as root, don't have permission to change the dir.
ls -l shows drwxr--r-- root root g
now as root WHAT is going on?
I tried
chmod 755 g ,
and get no errors but also no results
 
Old 02-24-2003, 06:13 PM   #2
almostlucky
Member
 
Registered: Apr 2002
Posts: 32

Rep: Reputation: 15
im pretty sure fat32 doesnt support permissions, so i beleive you will have to chage the permissions of the mount point
 
Old 02-24-2003, 06:21 PM   #3
sstudley
LQ Newbie
 
Registered: Feb 2003
Location: Tampa, FL
Distribution: Suse9.0, RH 8
Posts: 3

Original Poster
Rep: Reputation: 0
tried that umounted the drive and applied permissions, but that did not help when it mounted.
have it set up in fstab as user,rw,exec will triy to umask it next.
 
Old 02-25-2003, 04:17 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
umask is setting the permissions. Changing them on the mount point doesn't affect the filesystem, not with fat32 anyway. So yeah, umask is going to be what you need to look into

Cool
 
Old 02-25-2003, 06:52 PM   #5
sstudley
LQ Newbie
 
Registered: Feb 2003
Location: Tampa, FL
Distribution: Suse9.0, RH 8
Posts: 3

Original Poster
Rep: Reputation: 0
got it to work!
set it in fstab
/dev/hda5 /g vfat user,rw,exec,suid,umask=000 0 0
did the same for my ntfs partions except made sure that they stayed read-only.
If only I could get my major win apps to run in linux, will check wine out a little more...
need someone like those guys from winternals that really know ntfs to write a r/w driver!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot change permissions as root??? Kramer Linux - General 2 08-24-2005 07:31 AM
Root cannot change file permissions. aje Slackware 3 08-12-2005 02:27 AM
Root can't change file permissions!!!!!! j_pooria Fedora 1 08-19-2004 03:29 AM
Cannot change sg0 and scd0 permissions even as root Patrique Linux - Software 1 06-09-2004 04:08 AM
Change my user to root permissions metalaid Linux - Newbie 5 01-19-2004 08:17 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration