LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-16-2004, 07:36 AM   #1
nikoz
Member
 
Registered: Feb 2004
Posts: 46

Rep: Reputation: 15
Cannot boot! kernel panic


Hello to everyone..i would like some help here.On my hard disk i have installed windows xp and suse 8.1.Up to 4 days ago everything was working perfect.But when i pulled out from hard disk and from motherboard the data cable(rj?) and put it back 1 hour later,the system could not boot.Lilo begins i choose linux and when it reaches the point where checks for partitions it stucks.I can pass this by using as a boot option ide=nodma but then it stucks again by saying.Kernel panic! VFS couldn't mount root 03:03(something like that)I use hda1 for windows and hda3 for linux.The only way that i can log in is by using the 1st CD of linux-->installation safe setting-->boot current system.I tried to have a look in yast at bootlloader configuration option but i am not quite sure what to do.I think 1st thing it asks is where bootloader should be installed 1.Master boot hda...... 2.Boot sector .. 3 .. .4.. I chose the first one.Anyway..any idea what happened?any suggestions?please...(why happened this now that i am doing my dissertation..!*&~@)
Thanx
 
Old 03-16-2004, 07:55 AM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Check the BIOS setting for your hd.
 
Old 03-16-2004, 10:41 AM   #3
nikoz
Member
 
Registered: Feb 2004
Posts: 46

Original Poster
Rep: Reputation: 15
i have already did that.I went to hdd ide auto detection and it detects my hard drive as a primary master..
 
Old 03-16-2004, 10:46 AM   #4
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Make sure it is using dma
 
Old 03-17-2004, 09:11 AM   #5
nikoz
Member
 
Registered: Feb 2004
Posts: 46

Original Poster
Rep: Reputation: 15
how?

how am i going to do this?to make sure that is using dma?I check the bios settings..but i cannot understand just because i pulled out the cable and put it back again it doesnt work?In windows i can log in(with a delay)..In linux i cannot log in even with the safe settings option.Is it a kernel problem?Why it says kernel panic?Or maybe the cable causes the problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic on boot MasterOfTheWind Linux - Newbie 2 08-12-2004 02:52 PM
Kernel Panic at boot from Promise ATA100 w/ Kernel 2.6 MikTheUser Linux - Hardware 9 07-24-2004 02:24 PM
Kernel Panic during boot inTUXicated Linux - Newbie 5 03-06-2004 04:59 PM
Kernel panic on boot from cd? Crunch Linux - Newbie 3 03-05-2003 05:37 PM
Kernel Panic during first boot MasterC Linux From Scratch 6 06-12-2002 02:06 AM


All times are GMT -5. The time now is 09:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration