LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-10-2006, 03:06 AM   #1
sixgun
LQ Newbie
 
Registered: Aug 2006
Location: West Lafayette, OH
Distribution: Ubuntu 6.06 LTS, 6.10
Posts: 5

Rep: Reputation: 0
Can not run Update Manager; Synaptic broken


When I open the Synaptic Package Manager, I get the following message: "E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem."

So I ran the command, and it returns: "dpkg: parse error, in file `/var/lib/dpkg/updates/0000' near line 1:
newline in field name `#!/bin/sh'"

And when I try to run the Update Manager, I get this message: "Only one software management tool is allowed to run at the same time
Please close the other application e.g. 'aptitude' or 'Synaptic' first."

But of course I don't have any of those tools open when I get that error.

The last significant thing I did, was create a shutdown/reboot script that removes a mysteriously reappearing line from "/etc/fstab", that tries to mount sda1. Considering that, I inspected the fstab file with the version I had backed up, and it appeared to be the same. Besides the line that I intended to remove was gone.

As an experiment, I moved the 0000 file that I was getting the parse error on, to a different directory. The result was just the exact same parse error for 0001. So I moved 0000 back.

The distro I'm using is Ubuntu 5.10 Breezy Badger. So please help if you can. I can't bear the thought of reinstalling ubuntu, considering the updates took about 18 hours to download. Yeah, I live in an area that has no other option but dial up.

Here is also a copy of 0000 and fstab.

0000:
------------------------------------------------------------
#!/bin/sh
set -e
# Automatically added by dh_makeshlibs
if [ "$1" = "remove" ]; then
ldconfig
fi
# End automatically added section
------------------------------------------------------------

fstab:
------------------------------------------------------------
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 /sharedfiles vfat defaults,umask=000 0 0
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
------------------------------------------------------------
 
Old 08-10-2006, 04:26 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Hmm..first I'd try to
Code:
ps -e |grep syn
ps -e |grep apt
to see if any synaptic or apt apps are running..if they are, kill them. After you're sure none is running, clear the local cache of packages. To make sure, use apt-get to fix possible broken dependencies and after this run apt-get update and try installing some package again..

I had this once when I happened to ctrl+c while apt was installing something..I believe something was left half installed, it made apt crazy and I had to do some tricks with apt-get to get it back to work. I'm not sure but I probably had to manually remove some package and reinstall it again to get this work..it's been so long ago, though.
 
Old 08-10-2006, 03:46 PM   #3
sixgun
LQ Newbie
 
Registered: Aug 2006
Location: West Lafayette, OH
Distribution: Ubuntu 6.06 LTS, 6.10
Posts: 5

Original Poster
Rep: Reputation: 0
I ran "ps -e | grep syn" and "ps -e | grep apt" neither returned anything. I cleared the package cache by running "apt-get clear" and by using the settings under synaptic. I tried to run "apt-get check" to see if it found any broken packages, but it just returned that parse error again.

So no luck. But you might be on to something. Once I thought about it, a couple days before I installed the script, I was trying to install the drivers for a HCF Rockwell/Conexant modem. The install eventually failed with a bunch of permission denied errors. And the package is definitely partially installed, cause I get a bunch of failures related to that package, during boot up. So would you suggest that I do a file search, and manually remove the files related to that package?
 
Old 08-12-2006, 01:02 AM   #4
sixgun
LQ Newbie
 
Registered: Aug 2006
Location: West Lafayette, OH
Distribution: Ubuntu 6.06 LTS, 6.10
Posts: 5

Original Poster
Rep: Reputation: 0
Finally, it works. I tried removing all the files that I could find related to the HCF modem, but it made no difference. So I thought, maybe if I could reinstall dpkg, I might be able to fix the problem. Of course the problem with that idea is, all of my installation apps for ubuntu were crippled. So I decided to install dpkg manually. I booted with my live cd of ubuntu 5.10, and did a file search for all file names containing the string "dpkg". Then I replaced all of those files on the hdd with the copy of the files that was loaded into memory by the live cd. It was a long painful process, especially because I made backups of the originals before I replaced them, but it mostly paid off.

Although, it did leave me with a minor new problem. Since the live cd is just like a clean install, synaptic and the update manager only shows that I have the stuff installed that you have after a clean install. It doesn't realize that I already have all the updates and and programs installed. But all those apps and updates still work. So like I said, it's kind of minor to where I was a few hours ago.

Thanks for trying to help. And if any one could give me a lead to how to fix the new minor issue, please post. If I find a solution before then, I'll post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic Package Manager/Add applications broken LadyArtemis Ubuntu 7 05-07-2006 01:30 AM
synaptic package manager forcing me to delete a broken package mbman Linux - Software 6 04-25-2006 09:30 AM
Synaptic Package Manager bignester Linux - Software 1 09-08-2005 04:50 AM
Synaptic always considers OpenCV-0.9.6 broken? Any idea? jiapei100 Linux - Software 1 03-07-2005 04:52 AM
Making synaptic ignore broken packages ???? UsualTuxpect Linux - Software 5 09-05-2004 10:29 PM


All times are GMT -5. The time now is 07:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration