LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 07-10-2003, 10:58 AM   #1
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Rep: Reputation: 15
Question Can I run X without a mouse / or without a mouse cursor?


Hello. I am currently building a powerwall with a linux cluster. Each node is driving a projector. The problem I am attempting to correct is to get rid of the mouse cursor on the wall nodes.

So when I start up the X server with xinit, I am seeing a mouse cursor. I would like there to be no cursor at all. I have attempted to disable the mouse completely but I always get the "no core pointer" error when I try to start up the X servers.

If anyone can help me with this problem I would appreciate it greatly. Thanks.

So can I either kill the mouse completely or change the mouse cursor to something that is completely black? It seems like I have tried all the options in man XF86Config and man xterm and man xinit.

Thanks!
 
Old 07-10-2003, 11:10 AM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
What if you were to completely remove the section in your XF86Config for you mouse?
 
Old 07-10-2003, 11:24 AM   #3
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
I tried removing all InputDevice sections from the XF86Config file, to no avail. I also tried to use the Keyboard0 as the "Core Pointer Device"... still crashes on startup with the "No Core Pointer" error.

I also tried to use the Option "AllowMouseOpenFail" "boolean" flag in the server section of the file... this doesn't appear to do anything at all (see man XF86Config).

This is a question for the true Linux guru, and I am going to be impressed is someone figures this one out. This seemingly simple problem has found me stumped.

It seems like the crux of this problem reside sin the fact that the X server "requires" a core pointer device.
 
Old 07-10-2003, 11:33 AM   #4
LogicG8
Member
 
Registered: Jun 2003
Location: Long Island, NY
Distribution: Gentoo Unstable (what a misnomer)
Posts: 380

Rep: Reputation: 30
Did you delete the entry in ServerLayout as well?

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer" <--Delete
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

It should look something like this. Get rid of the
Core mouse entry and it will run without a mouse.
 
Old 07-10-2003, 12:44 PM   #5
bunhead
LQ Newbie
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: slackware
Posts: 20

Rep: Reputation: 0
no mouse under X

X will not start unless it sees something for a mouse. YOu could try to change your

Option "Device" "/dev/mouse"

to

Option "Device" "/dev/null"

but with that I think that you will still have a mouse pointer on the screen. Yup you will I just tested it. Are you runnign jsut Xfree86 by it's self? Or do you have a desktop enviroment running as well? Lemmie do some research into the mouse pointers under just plain XFree86. I will post later.
 
Old 07-10-2003, 02:05 PM   #6
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
I think its possible to use a custom mouse cursor (I'm not sure, I could be wrong).... maybe you could edit the mouse cursor to be a single pixel? It wouldn't be completely gone, but it would at least be hard to spot...

slight
 
Old 07-10-2003, 03:33 PM   #7
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Yes, I am just running the raw X server with one xterm window open with the background set to black. I still see the 'I' cursor on the screen, however.

Yes, I have tried setting the mouse to dev/null...

If I could edit the mouse cursor, the problem would be solved, because I could just use a black cursor that would be invisible against the black background.

When I blast openGL streams across the network, each node behaves properly and the cursor will disappear. But when the openGL app closes, the cursor returns (unless of course I have pushed it across the screen). This works for now, but I will eventually have 27 nodes, so I must find a solution to this. I can't realistically "push" the mouse cursor off the screen for 27 different nodes that make up the powerwall.

A am still searching... I can't find the pixmap that makes up the raw X server cursor yet. I will still be amazed if someone figures this one out., and more than that I will be very thankful.

Thanks for trying to figure out this puzzle. If I find a solution I will definately post it here.
 
Old 07-10-2003, 04:09 PM   #8
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
possible solution

This might help lead you to a possible solution. It is a small HOWTO describing how to edit the X cursor to be transparent.... its a little old, so I don't know if this is still accurate, but hey, its a start.

*continues googling for an answer*

slight
 
Old 07-10-2003, 04:14 PM   #9
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Thanks for that link. That looks to contain infomation that I didn't have. I will post here after I give it a shot and let you know how it turns out. Thanks again.
 
Old 07-11-2003, 09:57 AM   #10
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Well, I have still been unable to fix this problem. I feel like I am getting closer, however. I still unsure exactly where the mouse cursor is coming from and man X, xterm, xinit, xsetroot, xset, xmodmap, xrdb, xev, xlib.... none of these man pages explains this.

Has anyone had any success editting mouse cursors?
 
Old 07-11-2003, 12:35 PM   #11
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
Another possibly helpful link. I played around with this program last night and was able to change my cursors (Slack 9 install). Keep at it, I'm sure you'll be able to find a solution.

slight
 
Old 08-10-2003, 12:17 PM   #12
LogicG8
Member
 
Registered: Jun 2003
Location: Long Island, NY
Distribution: Gentoo Unstable (what a misnomer)
Posts: 380

Rep: Reputation: 30
To get rid of the mouse completely (but not the cursor)
you can use the "void" input driver

Section "InputDevice"
Identifier "Void1"
Driver "void"
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Void1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection
 
Old 09-23-2003, 05:17 PM   #13
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Ok, I discovered a way to get rid of the mouse cursor completely without having to blowaway any font files, reconfigure hardware settings, etc... quick and easy:
First, you need to create two bitmaps, which is very painless. Just use the 'bitmap' program and use its defaults. For one, choose 'envert' to make all pixels black. For the second, leave them all untouched. Save each file.

Now use the xsetroot command as follows

xsetroot -cursor <bitmap1> <bitmap2>

Now your mouse cursor is completely transparent when moved over the main window.
 
Old 09-24-2003, 05:48 AM   #14
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 245

Rep: Reputation: 31
Instead of messing with XF86Config-4 just set the cursor color in the xterm.
From man xterm:
-cr color
This option specifies the color to use for text cursor. The
default is to use the same foreground color that is used for
text.

Hope this helps.
 
Old 09-24-2003, 11:20 AM   #15
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Thanks, that is interesting.

However, I am actually running applications across these "blank" X servers. So as soon as something appears on the screen that is not that color, the cursor becomes visible.

By creating a an black and "white" cursor, using the bitmap and xsetroot commands (the cursor and the mask), you can make the cursor completely transparent. So it will take on the exact color of whatever is placed underneath it.

I have created a very large "virtual desktop" using a linux cluster, and I do not need 27 mouse cursors all over the 'screen'. Imagine how annoying it would be if you started your desktop and there were 27 "unmovable" mouse cursors all over your screen.

Thanks for all this help, guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No mouse pointer (cursor), mouse does work whizz Linux - Hardware 6 04-04-2006 10:00 PM
Is this possible, mouse/ mouse cursor related. beejayzed Linux - Software 1 09-18-2005 10:22 PM
[Mouse cursor] flicking on animated cursor Creak Debian 1 06-10-2005 03:16 AM
Mouse cursor changes-not! jhansman Linux - Hardware 2 09-12-2003 04:47 PM
No mouse cursor Kocil Linux - Hardware 4 08-15-2003 08:13 PM


All times are GMT -5. The time now is 01:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration