LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-08-2006, 11:32 AM   #1
linuxinvasion
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Can I launch a complete Gnome desktop session using SSH via PuTTY?


Hello, I am trying to establish a remote Gnome desktop session into a Red Hat linux server running the Enterprise 4.3 OS. From my Windows laptop, I first create a SSH X11 forwarding session using PuTTY (v0.56) into the linux server. I chose PuTTy because of the need for a secure encryption. I then launch my Hummingbird Exceed V7.1 process in the background. My question is, how can I launch the Gnome desktop from the command line? I've tried the following command below, but as you can see, I get a lot of warning/error messages. The Gnome desktop does indeed display, but I question some of its functionality. Am I using the right command? Is there a better way to establish a remote but secure Gnome desktop session?

Thanks.


# /usr/bin/gnome-session &
[1] 13427
# SESSION_MANAGER=local/aidir2-linux:/tmp/.ICE-unix/13427
Window manager warning: Log level 32: could not find XKB extension.

** (eggcups:13442): CRITICAL **: couldn't connect to session bus: Unable to dete
rmine the address of the message bus

** (gnome-panel:13436): WARNING **: Unable to load panel stock icon 'gnome-debia
n'

Gnome-Message: gnome_execute_async_with_env_fds: returning -1

** (gnome-panel:13436): WARNING **: Unable to load panel stock icon 'gnome-suse'

looking for type: got text/plain
looking for type: got text/plain
looking for type: got application/x-gnome-app-info
Unable to open desktop file applications:///Office/redhat-word-processor.desktop
for panel launcher: Error reading file 'applications:///Office/redhat-word-proc
essor.desktop': File not found
Unable to open desktop file applications:///Office/redhat-presentations.desktop
for panel launcher: Error reading file 'applications:///Office/redhat-presentati
ons.desktop': File not found
Unable to open desktop file applications:///Office/redhat-spreadsheet.desktop fo
r panel launcher: Error reading file 'applications:///Office/redhat-spreadsheet.
desktop': File not found

[root@aidir2-linux ~]# manager.c/1070: Received 'die', initiating shutdown
manager.c/1003: unmounting all volumes that we saw mounted in our life

(nautilus:13438): Eel-CRITICAL **: file eel-preferences.c: line 872 (preferences
_entry_remove_callback): assertion `entry->callback_list != NULL' failed

** (nautilus:13438): WARNING **: destroyed file still being monitored

** (nautilus:13438): WARNING **: destroyed file still being monitored

** (nautilus:13438): WARNING **: destroyed file still being monitored

** (nautilus:13438): WARNING **: destroyed file still being monitored

(nautilus:13438): Bonobo-WARNING **: Leaked a total of 1 refs to 1 bonobo object
(s)
/usr/bin/gnome-session &
[2] 13715
[1] Done /usr/bin/gnome-session

End of error/warning output
 
Old 11-08-2006, 11:44 AM   #2
kotnik
Member
 
Registered: Nov 2004
Location: Novi Sad, Serbia
Distribution: Debian, Slackware, Gentoo, openSuSE
Posts: 254

Rep: Reputation: 31
There is a better way: VNC.
 
Old 11-08-2006, 11:46 AM   #3
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Have you tried an XDMCP session from Exceed?
 
Old 11-08-2006, 12:14 PM   #4
linuxinvasion
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Reply to crabboy, kotnik

Currently looking into the VNC software. Thanks for the reply.

Have used XDMCP successfully but we are not allowed to continue its use due to its lack of encryption. Thanks for the reply.
 
Old 11-08-2006, 12:16 PM   #5
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Use the XDMCP within the putty ssh tunnel.
 
Old 11-08-2006, 12:25 PM   #6
linuxinvasion
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Original Poster
Rep: Reputation: 0
REPLY to crabboy

The way that I was using XDMCP was to open the Xsession utility from the Windows Hummingbird Connectivity | Exceed | Xsession menu item and to set up the options page as:

Window Mode = single
Startup Mode = XDMCP-query
Connect Host = <IP address of the Red Hat 4.3 server>

How can I use XDMCP with the putty ssh tunnel?

Thanks again.
 
Old 10-28-2008, 01:52 PM   #7
Arfyness
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Rep: Reputation: 0
Forwarding a local port via putty

Quote:
Originally Posted by linuxinvasion View Post
How can I use XDMCP with the putty ssh tunnel?

Thanks again.
Look in the tunnel part of the session manager for putty. There you can define tunnels. Keep in mind the following:

Local means you're forwarding a port on the local computer so that it connects to a port on another machine. The following is useful to ssh to a machine, and create a secure tunnel to a port ON THAT MACHINE. Let's say you want to make a typical FTP tunnel, where all the data goes on port 20.

Local port: 21
Remote: localhost:21

Local port: 20
Remote: localhost:20

Then, to use it, you would establish an FTP session to your own machine:
ftp> open localhost

You can also use it to access other machines, with the apparent connection coming from the box you are ssh'ed into host. For example, I use it to get to the config page of a printer or router behind a firewall.

Local port: 8080 (can be anything)
Remote port: 192.168.1.100:80 (whatever ip:port is appropriate)
then browse to http://localhost:8080/

So, whatever port(s) you need for XDMCP, forward those through the tunnel like that, and have Exceed connect to localhost on those ports.

Hope that makes enough sense.

Note: Your tunnels may linger active for a while even after you've ended your ssh shell session. Exiting putty will close the tunnels.

Also note: in a Linux shell, the preceding examples become:
ssh -L 21:localhost:21 -L 20:localhost:20 user@host
-- and --
ssh -L 8080:192.168.1.100:80 user@host

It looks like Plink takes the same arguments, if you don't really need a shell session at the same time.

see also: http://the.earth.li/~sgtatham/putty/...doc/index.html

This is really useful for all kinds of things, including VNC. Personally I do NOT AT ALL feel safe having a listening VNC port exposed to the bare 'net.

Dang, this is a longer reply than I expected to write.

-- Nate

Last edited by Arfyness; 10-28-2008 at 02:01 PM. Reason: clarified abiguity
 
Old 10-28-2008, 02:10 PM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,008

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
Dang, this is a longer reply than I expected to write.
This thread is almost 2 years old. Which also means that it is probably longer than linuxinvasion (three posts in two years) expected to wait for a reply

But I expect somebody will be grateful for your follow-up
 
Old 06-05-2011, 10:22 AM   #9
collette
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by tredegar View Post
But I expect somebody will be grateful for your follow-up
I am!
 
Old 06-05-2011, 10:39 AM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,135
Blog Entries: 3

Rep: Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405
Hi,

Welcome to LQ!

Quote:
Originally Posted by collette View Post
I am!
There is no reason for the type of response that you gave to a old thread.

Please look at the LQ Rules again, especially the following;

Quote:
excerpt from LQ Rules
  • Do not post if you do not have anything constructive to say in the post.
  • When posting in an existing thread, ensure that what you're posting is on-topic and relevant to the thread. If the content of your post will interfere with the current discussion, you should start a new thread.
Resurrecting old threads with your type of response helps no one. Not constructive & hijacks the thread. So in the future, please be aware of the post content and how it relates to the thread you are posting to.
HTH!
 
  


Reply

Tags
desktop, exceed, forwarding, gnome, gnomesession, putty, x11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure VNC server to load up the complete GNOME desktop? tlawlessrr Linux - Newbie 8 03-21-2014 08:21 AM
2 Gnome questions, mount desktop icon & launch notification McCloud Debian 3 07-02-2007 09:01 PM
Disable startkde and gnome-session over ssh deepaklukose Linux - Networking 5 01-18-2006 05:07 PM
Putty SSH remote desktop Solved learner_driver Linux - Networking 1 07-05-2004 03:02 PM
how to use vnc to launch gnome desktop asadhussain Linux - Networking 1 10-15-2003 01:24 PM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration