LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-12-2005, 01:32 PM   #1
Okie2003
LQ Newbie
 
Registered: Nov 2004
Location: Oklahoma
Distribution: Mepis
Posts: 21

Rep: Reputation: 15
Can't boot to another Linux kernel from boot loader


I hope I am on the right forum. I am running Mepis. When I choose either the 2.4 or the 2.6 kernel to boot the live CD and then install from it I can't pick the other kernel in the boot loader when I reboot from the hard drive. I get "Kernel panic: VFS: unable to mount root fs on unknown-block(0,0)" This happens whether I am going from 2.4 to 2.6 or from 2.6 to 2.4. I have done a complete reformatting of the drive, not just the partition, and there is no change. As long as I always boot to the same kernel Mepis seems to run fine. I am at the point where all of my work and applications (Win4Lin, etc.) and settings are installed and I don't want to reformat again, especially since it didn't help before.

I have noticed that when I perform a successful boot these two messages appear:
"Mount: fs type sysfs not supported by the kernel"
"You didn't specify filesystem type for /dev/hdb3 I will try ext3"
How do I now specify this file type? Could this be related to the problem described above? If so, the root partition is hdb1. Home partition is hdb3.

If I am on the wrong forum, could someone point me in the right direction? Thanks in advance for your help.
 
Old 01-12-2005, 01:44 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
what boot loader?
whats your config?

also, notice it's trying to bring the root partition up on hd(0,0) where yours is actually hd(1,0) so something in the install didn't get configured (with the bootlader)
 
Old 01-12-2005, 01:45 PM   #3
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
You specify filesystems in /etc/fstab

sysfs is, I believe, part of the /proc virtual filesystem - enabled in the kernel
 
Old 01-12-2005, 02:32 PM   #4
Okie2003
LQ Newbie
 
Registered: Nov 2004
Location: Oklahoma
Distribution: Mepis
Posts: 21

Original Poster
Rep: Reputation: 15
System configuration: Soyo MB SY-KT600 Dragon Plus v1.0, Athlon XP 2600 Barton, MSI GeForce 2 MX400 video card, 512 MB RAM, hda1 is a 6GB Seagate FAT32 Windows drive, hdb is a 80 GB Western Digital. hdb has three partitions: hdb1 is 9.7 GB ext3, hdb2 is a linux swap at 996MB, and hdb3 is 63.8 GB ext3 according to QTParted. Hope this is all you need.

The boot loader is Grub v 0.95 I found this in /boot/grub/menu.lst and thought it might be helpful:
title MEPIS at hdb1, kernel 2.6.7
kernel (hd1,0)/boot/vmlinuz-2.6.7 root=/dev/hdb1 nomce psmouse.proto=imps quiet splash=verbose vga=791
initrd (hd1,0)/boot/initrd.mepis
savedefault

title MEPIS at hdb1, kernel 2.4.26
kernel (hd1,0)/boot/vmlinuz-2.4.26 root=/dev/hdb1 nomce quiet splash=verbose vga=791 hdc=ide-scsi hdd=ide-scsi
initrd (hd1,0)/boot/initrd.mepis
savedefault

title Windows at hda1
rootnoverify (hd0,0)
chainloader +1
savedefault

Finally, fstab shows:
/dev/hdb1 / ext3 defaults,noatime 1 1
/dev/hdb2 swap swap sw,pri=1 0 0
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /dev/pts devpts mode=0622 0 0
none /sys sysfs defaults 0 0
/dev/hdb3 /home auto defaults,noatime 1 2
# Dynamic entries
/dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,users,dev,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,users,dev,ro 0 0
/dev/floppy /mnt/floppy vfat,ext2,hfsplus noauto,users,dev 0 0

I really don't know what much of this means. If other info is needed I will try to find it. Thanks.
 
Old 01-12-2005, 04:23 PM   #5
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
Try replacing
/dev/hdb3 /home auto defaults,noatime 1 2

with
/dev/hdb3 /home ext3 defaults,noatime 1 2

Also, I could be wrong, but I think that
none /proc proc defaults 0 0

should be
proc /proc proc defaults 0 0

Lastly, I don't know Mepis, but see if you have a directory /etc/modules.autoload.d/ with a file in it called kernel-2.4 or kernel-2.6

If so, you may be having trouble with switching kernels because you haven't got the appropriate settings for the other kernel, ie if you have kernel-2.4 and you try to use 2.6, it'll be unable to find the necessary kernel-2.6 file
 
Old 01-13-2005, 06:20 PM   #6
Okie2003
LQ Newbie
 
Registered: Nov 2004
Location: Oklahoma
Distribution: Mepis
Posts: 21

Original Poster
Rep: Reputation: 15
Unhappy Yes and No

Well the above changes did get rid of "You didn't specify filesystem type for /dev/hdb3 I will try ext3", but I still have "Mount: fs type sysfs not supported by the kernel". Worst of all, it did not fix the problem of booting to a different kernel. Well, at least it didn't harm anything

I don't seem to have /etc/modules.autoload.d/ or anything that looked close.

Thanks for your time. I am willing to try other ideas.
 
Old 02-01-2005, 08:21 AM   #7
Okie2003
LQ Newbie
 
Registered: Nov 2004
Location: Oklahoma
Distribution: Mepis
Posts: 21

Original Poster
Rep: Reputation: 15
Follow up -- FIXED

I know this is an old thread, but I fixed my problem of not being able to switch kernels by disabling SATA in the BIOS. This also enabled the LAN in kernel 2.6

Thanks for all you help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To load/boot Red Hat Enterprise Linux 4 WS from Microsoft's Boot Loader (NTLDR) dhawal Red Hat 1 09-25-2005 07:08 AM
To load/boot Red Hat Enterprise Linux 4 WS from Microsoft's Boot Loader (NTLDR) dhawal Linux - General 1 09-25-2005 07:07 AM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
Kernel update boot problems, no boot loader StaticSage Red Hat 2 01-09-2004 06:05 AM
Kernel Compile Boot Loader? boot disk? SPMcRuube Linux - Newbie 3 12-03-2002 07:02 PM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration