LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-15-2007, 12:08 AM   #1
niko9enzo
LQ Newbie
 
Registered: Oct 2007
Posts: 17

Rep: Reputation: 0
Canīt see every file in NTFS mounted partition


Hi everyone. Im having an unusual problem, I googled and searched the forums for a while to see if someone has the same problem but didnt find anything. The problem is this:
I have a mounted NTFS (extended logical) partition and canīt see every single file on it. for example, I have videos numbered from 1 to 10 in a folder and cant see everyone of them. I can see some of them, for example i can see 1,2,4,5,9,10 but cant see 3,6,7,8. I can see most of the files on the partition though, but not ALL of them. Under windows, all those files have exactly the same attributes, so i cant figure out why it can detect some and not the others.
The partition is mounted using the ntfs-3g driver.
I am using slackware 11.0 on a p4 2,26hz 1,5gb ram.
When I switch to windows xp i can see all of the files. but i dont want to have to switch to windows to see my files :S
Has this happened to anyone??? Any ideas?? If anyone comes up with some way to see those missing files I would greatly appreciate it
If you need more info please let me know and iīll post it.
thanks
nico
 
Old 11-15-2007, 07:10 AM   #2
AnanthaP
Member
 
Registered: Jul 2004
Location: Chennai, India
Distribution: UBUNTU 5.10 since Jul-18,2006 on Intel 820 DC
Posts: 634

Rep: Reputation: 139Reputation: 139
Upfront it looks like a problem with the interpretation of long file names (also called as LFN). You must have used the `mount` command to check what is the result. What does it say?
 
Old 11-15-2007, 12:55 PM   #3
niko9enzo
LQ Newbie
 
Registered: Oct 2007
Posts: 17

Original Poster
Rep: Reputation: 0
Hi, im not sure i understand what you mean by using the mount command to check. This is the output of the mount command:
/dev/hdb1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,devgid=10,devmode=0666)
/dev/hdb5 on /home/niko/0.hdb5 type ext3 (rw)
/dev/hda1 on /c.winxp type fuseblk (ro,noexec,nosuid,nodev,sync,noatime,allow_other,default_permissions,blksize=4096)
/dev/hda5 on /d.niko type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
//niko-w/c.niko-w on /niko-w/c.niko-w type smbfs (0)
//niko-w/d.niko-w on /niko-w/d.niko-w type smbfs (0)
//niko-w/shared.files.c on /niko-w/shared.files.c type smbfs (0)
//niko-w/shared.files.d on /niko-w/shared.files.d type smbfs (0)

is this what you were asking??
I will google for LFN to see if I can come up with something
 
Old 11-15-2007, 01:46 PM   #4
niko9enzo
LQ Newbie
 
Registered: Oct 2007
Posts: 17

Original Poster
Rep: Reputation: 0
hi everyone! i found the solution. it was in the support of the ntfs-3g homepage. sorry to cause trouble :S
Hereīs what i found:
Missing, disappeared files or directories? or
Why can't I see all filenames with national characters? or
Why do I get "Skipping unrepresentable filename (inode XXXXX) ..." messages?
This means that your operating system (OS) doesn't have the correct language specific settings (locale, LANG variable, LC_ALL, etc) thus some filenames can't be converted to your language and won't be visible. The reason can be:
The locale setting wasn't configured during installation.
Not the correct locale was configured.
The configured value doesn't exist on the system.
The OS configures the setting in a too late stage during the boot process, only after the NTFS volume was already mounted.
The most common explanation is the latter one. This is why unmounting then mounting such volumes after boot often makes all filenames visible.
Solution: The OS vendor should move the language specific configuration to an earlier phase to precede the mounts of the NTFS volumes in time.

Workaround: ntfs-3g supports the 'locale' mount option which can be used to set the correct language value. You can see what locales you have on your system by using the following command:

So in my case i just unmounted and remounted the ntfs partition and i can see all of the files now!, now i dont have to go back to windows =) =) =)

thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - sharing mounted NTFS partition SirAeryn Linux - Networking 2 09-11-2005 08:54 PM
Problem reading mounted NTFS partition... Virak Linux - Newbie 8 08-18-2005 04:38 PM
NTFS partition cannot be mounted after converting from FAT32 aweir14150 Mandriva 5 01-27-2005 03:11 PM
Allowing read/write on mounted captive-ntfs partition divsky Linux - General 6 04-15-2004 10:52 AM
permission of mounted NTFS partition demmylls Linux - Security 2 11-29-2003 11:08 PM


All times are GMT -5. The time now is 04:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration