LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-26-2003, 02:24 PM   #1
felkin
LQ Newbie
 
Registered: Jun 2003
Posts: 11

Rep: Reputation: 0
can't start remote X session PAM error


I'm a little lost. I can startx locally on my linux (RH9) box with both root and users. However, when I ssh into the linux box from cygwin (on windowsXP) and try to startx, I get errors.

When an user, I get the following:

"PAM authentication failed, cannot start X server"

And, when I'm root I get something else: "client 4 rejected from local host".

What happens is that the Xserver starts locally on the linux machine instead of in cygwin on the XP machine.

My question is how do I get the Xsession to run via cygwin (on windowsXP)? Do I need to do something on the linux (RH9) box or with the cygwin (on windowsXP)?

I am only doing this because I hope that it is faster than running VNC. (I already have VNC running and it works, just okay though.)


Thanks for reading,

Rob
 
Old 11-29-2003, 12:36 PM   #2
PatomaS
LQ Newbie
 
Registered: Oct 2003
Location: Kuala Lumpur
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
Question

Hmmmm

I can start my Gnome desktop, but just as root, and no as user...

and have the same messages

...
client 4 rejected from local host

any idea?
 
Old 06-28-2004, 07:10 PM   #3
calango
LQ Newbie
 
Registered: Jun 2004
Location: Brasil
Posts: 2

Rep: Reputation: 0
i am having problems with pam authentication to
i can only start X as root
whenever i try to start as a user, i get:
"PAM authentication failed, cannot start X server"
 
Old 07-13-2004, 03:56 PM   #4
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Rep: Reputation: 15
I guess no one knows the answer to this question. Googling leads to dozens of pages of this exact same question with not a single usable answer.

Just for the record, Suse 9.0 doesn't seem to suffer from this convoluted mess.

Does anyone have an answer to this?
 
Old 07-14-2004, 11:22 AM   #5
Guru3
Member
 
Registered: Sep 2003
Location: //home/sweden
Distribution: RedHat 9, Fedora Core 1
Posts: 360

Rep: Reputation: 31
I've worked on this today and I realize why was happening now with that error. When you run startx it tries to run the xserver, which of course you are already running on the local computer. So, try running gnome-session instead.
 
Old 07-14-2004, 01:09 PM   #6
jdaniel
Member
 
Registered: Jul 2003
Posts: 51

Rep: Reputation: 15
Ok, finally here is the solution to this problem:

-----------

Ah, you must be running red hat. Your pam authentication defaults to
strict settings. Rather than messing with the console.perm settings and
the other pam stuff, try this cheat...

Log in as root and create a file in /var/run/console/ that is the name
of the user you want to have permissions to start up an xserver. chmod
that empty file to 600. Now we can trick pam.. it will think your user
owns the console all the time now.

To see how this works you can log into the console as a normal user. Now,
as root, go inspect the /var/run/console directory. You will see a file
there named 'user_that_is_logged_in'. Now log out as that user. Inspect
/var/run/console. Now the file is gone. By creating it manually it
should just stay there all the time.

Hope this helps. Let me know if it works.
--------------
 
Old 08-25-2004, 08:27 PM   #7
snatmanlinux
LQ Newbie
 
Registered: Aug 2004
Location: U.S.A.
Distribution: RH9
Posts: 2

Rep: Reputation: 0
Thank you very much, jdaniel.

That did the trick. Any users that I add that way are accepted. I am also running RH9, but am not very good at it yet. I mostly use this box for seti and playing DVD's, because it does better then Winblows ON THE SAME HARDWARE!! LOL. I was playing with it and installed samba. Thinking that was what changed auth settings.
There are a lot of web sites that have this error, but only you could fix it. Thank you again!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while trying to start a program on a local X session. Vorik Linux - Software 0 01-28-2005 01:50 PM
Long delay and error message starting remote X session lotus49 Linux - General 3 10-11-2004 01:20 PM
start VNC in remote x session yourEgg Linux - Networking 0 05-17-2004 05:48 PM
Command to start remote KDE session on Debian The_Fed Linux - Newbie 1 04-19-2004 04:31 PM
How to start a remote X session? ejennings_98 Linux - Newbie 2 02-22-2004 10:08 PM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration