LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-16-2004, 07:46 AM   #16
mr_a_ali
Member
 
Registered: Aug 2004
Location: USA
Distribution: SuSE 9.1 (Personal)
Posts: 49

Rep: Reputation: 15

Will I have to do this every time I want to run WINE? Or will it be permanent?
 
Old 08-16-2004, 08:41 AM   #17
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You need to use a better distro or report a bug against SuSE. The correct way for this to work is for it to be transparent and automatic like on fedora, using pam_xauth.

Alternatively use a program called "sux".

Finally there's no need to run wine as root
 
Old 08-16-2004, 11:29 AM   #18
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
Quote:
ssh would be the safest easy way.
If the machine is multiuser people could
play tricks on you by opening stuff in
your session if you have xhost +local
(or localhost, for that matter) enabled.
My machine is not mulituser. Furthermore, since only users using the current computer are allowed to open windows (since it's xhost +local), how could people play tricks on you?

I would rather avoid ssh because then there would have to be an extra process in memory using resources (even if it's a small amount). Furthermore, I have no need to log into my computer remotely so I can be more sure it's secure if sshd isn't even running.
 
Old 08-16-2004, 05:40 PM   #19
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
Quote:
xhost really is a kludge.
Do you mean the code is badly written and the program is buggy, or that the very nature of the program (controlling access of who can control your own X Windows session) is a bad idea and unnecessary?
 
Old 08-17-2004, 03:47 PM   #20
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
The latter :)

I'm a security fanatic, call me professional paranoid ;)


Cheers,
Tink
 
Old 08-19-2004, 02:11 PM   #21
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
xhost is unnecessary on incorrectly set up distributions, so it's kind of a hack. But this is the problem with having so many distros ....
 
Old 08-19-2004, 03:32 PM   #22
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
Quote:
xhost is unnecessary on incorrectly set up distributions
Did you mean "on correctly set up distributions"?
 
Old 08-19-2004, 04:21 PM   #23
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
oops, yes, must be tired
 
Old 08-19-2004, 08:06 PM   #24
forgox
LQ Newbie
 
Registered: Jul 2004
Posts: 27

Rep: Reputation: 15
Hi,
Trying "xhost +local:" on user shell works well when running as root in root shell after using "su". Launching X application works well.

On Debian Testing, it seems that when using "su -" to have a root shell to really run as root using root's environment setup (.cshrc etc.) launching X application don't work. "xhost +local:" seems useless. Shutting down the firewall, setting DISPLAY=:0.0 in root shell, doing xhost - (from the user account) doesn't help. It seems that on RedHat it's working fine!

Is there a trick to be able to run X application when doing "su -"?

thanks
 
Old 08-19-2004, 08:18 PM   #25
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
Interesting - using "su -" then opening GUI programs works the same for me as using plain "su". Maybe you should submit a bug report to Debian.
 
Old 08-19-2004, 08:42 PM   #26
forgox
LQ Newbie
 
Registered: Jul 2004
Posts: 27

Rep: Reputation: 15
Hi,
This might is probably not a Debian bug but rather something that a root script does when invoking "su -" .
 
Old 08-19-2004, 09:24 PM   #27
g4c9z
Member
 
Registered: May 2004
Location: Canada
Distribution: Gentoo
Posts: 36

Rep: Reputation: 15
Yeah - maybe it's changing $DISPLAY.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't run gui (X) programs as root user nazdrowie Linux - General 25 12-02-2008 02:24 AM
How to run GUI program as root shadkong Slackware 8 09-20-2005 03:24 PM
Unable to run a GUI app as root using su? vharishankar Linux - General 7 05-25-2005 09:08 AM
Best java ide for gui applications xiang83 Programming 3 01-27-2005 02:59 PM
Cannot run X applications as root jplev22 Slackware 8 02-15-2004 11:39 PM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration