LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-14-2003, 01:17 PM   #1
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Rep: Reputation: 15
Can't enter X


Dear Everyone,

here's a weird behavior:
while I'm in the frontend login, each key that I strike on my keyboard refreshes my display in different resolution.
I don't understand 'cause, yesterday, it was quite fine.
The only thing that I changed was putting the Num Lock on for the next restart.
I can not even do ALT+F1 to go to console.
Even ALT+Backspace and CTRL+ALT+Backspace can't bring me back before the graphical login.
I'm on Red Hat 9.0, using a MSI GeForce 4 MX440 on an Asus A7N8X Deluxe. I've got plenty of hard disk space and ram.
I remember that my XFree86config file correctly installed my Viewsonic and my video card (using nv for driver).
After all, it was working fine....

How can I stop the graphical login to load ?
 
Old 05-14-2003, 01:43 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Re: Can't enter X

Quote:
Originally posted by McNider
I can not even do ALT+F1 to go to console.
Try Ctrl + Alt + F1
Quote:
How can I stop the graphical login to load ?
Append " 3" to your kernel arguments at boot.

You could also try using "Ctrl & Alt & +" and "Ctrl & Alt & -" to set the resolution once X has loaded.
 
Old 05-14-2003, 02:04 PM   #3
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Same result.
Like I said: EVERY key on my keyboard resizes my display without entering any caracter at all !
... and my keyboard is working just fine in other OSes.
 
Old 05-14-2003, 02:20 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
In that case append " 3" (no quotes) to your kernel arguments at boot.
 
Old 05-14-2003, 02:24 PM   #5
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
you mean editing Grub at start and entering that parameter after loading vmlinuz ? (same line ?)
 
Old 05-14-2003, 03:04 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Yes at the end of the ie:
kernel /vmlinuz.version OTHER PARAMETERS 3
 
Old 05-14-2003, 04:29 PM   #7
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks for the help. I got in Kudzu, everything looks just fine. Then, on console, the keyboard behaves perfectly (well.... normally).
I logged in and typed startx.
Then.... same WEIRD behavior:

The mouse works fine but as soon as I type ANY key on my keyboard, BANG ! The display changes from 1024*768 to 640*480 and to 800*600 etc.. (KDE and Gnome)

Should I reinstalled an XFree86-kboard....rpm kind of thing ?
Or should I change my prescription ?



(I'll be back in 20 hours)
 
Old 05-14-2003, 04:38 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Do you have right settings for your keyboard in XF86Config?
 
Old 05-16-2003, 04:45 PM   #9
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Looks OK to me but If you see something suspicious...

I'll just copy & paste parts where the keyboard is mentionned...

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection
 
Old 05-29-2003, 11:19 PM   #10
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
13 Days later...

Having still the same problem...

Here's a cue though:
While looking at my /var/log/gdm files, I've come across this warning line under the section The XKEYBOARD keymap compiler (xkbcomp) reports:

> Warning: Multiple interpretations of "NoSymbol+AnyOfOrNone(all)"
Using last definition for duplicate fields

and this line comes after this:

expected keysym, got XF86_Prev_VMode: line 54 of XFree86

Obviously, that looks like Previous VideoMode, and that's exactly the reaction that I get when I strike any key on my keyboard.
I've checked line 54 in my XF86Config file but it's only a comment line.

Has anyone seen this before ?
And do you have ANY IDEA how I could get back my X server to work correctly ?
 
Old 06-02-2003, 03:54 PM   #11
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Conclusion

With the help from someone @ XFree86.org, my GDM now works again !
It seems that I had to refresh the file /usr/X11R6/lib/X11/XKeysymDB...
 
Old 07-12-2003, 01:19 AM   #12
crabbyman6
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
I am having the EXACT same problem and I would greatly appreciate if anyone knew how to fix it or if McNider could tell me. Thanks, its driving me crazy!!!
 
Old 07-13-2003, 03:12 PM   #13
McNider
LQ Newbie
 
Registered: Sep 2002
Location: Montreal
Distribution: Mandriva 2008
Posts: 28

Original Poster
Rep: Reputation: 15
Hey crabbyman6,

This link should provide you with the latest XKeysymDB file:
http://cvsweb.xfree86.org/cvsweb/~ch...ype=text/plain

But don't take a chance and make a backup of your own before !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I enter php interface like "python[enter]" in python backpacker Linux - Software 1 06-20-2005 08:38 PM
Enter the necromancer Venefyxatu LinuxQuestions.org Member Intro 5 05-05-2005 02:13 AM
"Disk boot failure. Enter system disk and press enter" Fear58 Linux - Hardware 3 06-25-2004 06:17 PM
can't enter password riverbed Linux - Newbie 2 01-30-2004 02:31 AM
how to enter code? correro LQ Suggestions & Feedback 10 03-11-2003 04:40 AM


All times are GMT -5. The time now is 11:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration