LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-26-2004, 03:38 PM   #1
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Burning dvd iso with K3b


I've been trying to burn an iso dvd (video), but when I start it up in k3b, it tells me that I have the wrong medium type. I am using the right type dvd. Here is the exact message:

Code:
:-( unable to open64("/dev/ide/host0/bus1/target0/lun0/cd",O_RDONLY): Wrong medium type
Thanks for any help.
 
Old 02-26-2004, 07:27 PM   #2
jlturbos
Member
 
Registered: Jun 2002
Location: Pennsylvania
Distribution: Anything and Everything
Posts: 61

Rep: Reputation: 15
Try burning on the command line first as root like this:
growisofs -dvd-compat -Z /dev/scd0=/location/and/name/of/dvd.iso

or:
growisofs -dvd-compat -Z /dev/scd0=/location/and/name/of/input/directory

Make sure you are using a new version of dvd+rw-tools and that the medium is formatted first if and only if it is dvd+rw. Only virgin media needs to be formatted, otherwise dvd+rw-tools will reformat it for you initially.

Also, you should use scsi emulation during boot:
append="hdc=ide-scsi"

Let me know if it works.
 
Old 02-26-2004, 08:00 PM   #3
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
I added the ide-scsi simulation, but when I put I still get errors. Growisofs output ":-( /dev/hdc: media is not recognized as recordable DVD: 0". I think it's because the drive is in read only (O-RDONLY), but I can't quite figure out what the problem is.
 
Old 02-26-2004, 08:15 PM   #4
jlturbos
Member
 
Registered: Jun 2002
Location: Pennsylvania
Distribution: Anything and Everything
Posts: 61

Rep: Reputation: 15
I'm sorry, I didn't realize you were running mandrake! You must take it out of it's automounter control. I would edit /etc/fstab and see if it is ro and contains supermount. Comment out that line and exit. Then, umount the device in question. Now burning should work. What dvd format are you trying to burn? dvd-r[w] dvd+r[w] dvd-ram, or what? That's important.

Try that and let me know.

JL
 
Old 02-26-2004, 11:52 PM   #5
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
I killed automount and ro, but am still getting the error. When I try to mount the drive, I get:

Code:
mount: block device /dev/hdc is write-protected, mounting read-only
mount: No medium found
Still Read-only. When I now try to get umount the drive, I get:

Code:
umount: /dev/hdc: not mounted
Okay, it seems that the drive isn't mount at all. Regardless, I go to k3b and try to burn a cd. I get the exact same error meessage as if it were supermount and ro, and I don't think the thing is mount at all! I'm really perplexed here. Thanks for the help.
 
Old 02-27-2004, 12:11 AM   #6
jlturbos
Member
 
Registered: Jun 2002
Location: Pennsylvania
Distribution: Anything and Everything
Posts: 61

Rep: Reputation: 15
If you have scsi emulation turned on you can't mount /dev/hdc you must mount like this:
# mount -t iso9660 /dev/scd0 /mnt/cdrom
or:
# mount -t iso9660 /dev/sg0 /mnt/cdrom
or:
# mount -t iso9660 /dev/sda /mnt/cdrom
assuming /mnt/cdrom exists and the cd or dvd contains an iso9660 fs, if not try "-t udf" for video dvds.

Are you trying to mount an empty cd or dvd. Obviously that won't work! I still don't know what type of dvd you are trying to burn, please let me know.

Regardless of what mounting does the following commands should work if
lsmod lists the ide-scsi module in its output:
# growisofs -Z /dev/scd0=/location/and/name/of/dvd.iso
# growisofs -Z /dev/sg0=/location/and/name/of/dvd.iso
# growisofs -Z /dev/sda=/location/and/name/of/dvd.iso

JL
 
Old 02-27-2004, 04:24 PM   #7
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
All of them are not found. I'm trying to burn a dvd-r. I've been playing around with all the settings, and can't seem to get any of it working.
 
Old 02-27-2004, 04:34 PM   #8
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Seems like the problem is isolated to hdc too, I'm able to burn regular cds on hdd just fine (it's actually a little slower than usual).
 
Old 02-27-2004, 05:38 PM   #9
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Hmm... It seems that I've been relatively stupid about this the whole time. I never had ide-scsi on, depsite my think I did. So I actually have ito n now, and use /dev/scd0. I tried with supermount and ro; failure. I tried supermount and no ro; failure. I tried no supermount, and now I can't mount it at all, I get permission denied as root.

On bootup, a message comes up saying that it is mounting it as read-only, as well as that it can't read superblock.

Last edited by Inexactitude; 02-27-2004 at 05:41 PM.
 
Old 02-28-2004, 12:57 PM   #10
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Very strange....I was able to burn a regular cd on the dvd drive, but I get medium errors when usinga dvd. I've tried dvd-r and dvd+r, all to no avail. What can I do to fix this up?
 
Old 02-29-2004, 03:05 AM   #11
michael@actrix
Member
 
Registered: Jul 2003
Distribution: OpenSUSE 11.4
Posts: 55
Blog Entries: 1

Rep: Reputation: 16
Quote:
Originally posted by Inexactitude
Very strange....I was able to burn a regular cd on the dvd drive, but I get medium errors when usinga dvd. I've tried dvd-r and dvd+r, all to no avail. What can I do to fix this up?
I take it it doesn't actually start the burn?
What's the error message exactly?
Is there anything in /var/log/messages or in the output from the dmesg command?
Do you run another OS that you could check out the drive with?

I'm using growisofs 5.17, k3b 0.11, with an MSI DR8-A DVD burner on RH9. So far DVD+RW and CD-RW/CD-R have all worked. This is under RH9 with kernel 2.4.20(RH) and 2.6.3.

The only problem I've had is when the unit was too hot and dmesg reported a tracking servo failure in the middle of a burn - this was after using the drive continuously for an hour including two simulated burns. After it cooled down it was fine.
 
Old 02-29-2004, 03:14 PM   #12
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
I was able to fix the problem. I tried burning the dvd from knoppix, which worked. So I then got the newest version of dvd-rw tools and compiled it from source, and then everything worked fine. I guess that the rpm package thar ships with mandrake is messed up.

Thanks for the replies.
 
Old 03-04-2004, 12:03 AM   #13
jlturbos
Member
 
Registered: Jun 2002
Location: Pennsylvania
Distribution: Anything and Everything
Posts: 61

Rep: Reputation: 15
The rpm that comes with Mandrake 9.2 for dvd+rw-tools was givin me hell too! I kept getting an error about the write speed being incorrect and it would refuse to burn. I spent 2 days trying to figure it out, finally I downloaded and compiled from source and I was burnin dvds within one minute!

Source rules, rpms suck, I'm moving to Slackware.
 
Old 03-04-2004, 02:16 PM   #14
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Original Poster
Rep: Reputation: 30
Now if only I can figure out how to burn the dvd so it'll play back...
 
Old 03-04-2004, 03:47 PM   #15
jlturbos
Member
 
Registered: Jun 2002
Location: Pennsylvania
Distribution: Anything and Everything
Posts: 61

Rep: Reputation: 15
Play back on what?
If you mean a standalone dvd video player then do:
# growisofs -dvd-compat

That command alone won't work, but if you add the -dvd-compat option to growisofs, it should work. Also, some media, dvd+rw I think needs:
# dvd+rw-format -lead-out /dev/your_device
after a burn in order to work!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
k3B Burning from ISO problem halojoy Linux - General 9 10-06-2005 05:39 PM
Burning ISO image (DVD+R, external DVD writer) swan2925 Linux - Software 6 06-02-2005 09:49 AM
burning dvd+rw with k3b FF103 Yoper 1 12-13-2004 06:31 PM
problems with k3b burning iso Xavius Linux - General 0 11-23-2004 07:01 AM
Burning ISO Image with K3b software ? dolphans1 Mandriva 4 08-20-2004 01:00 AM


All times are GMT -5. The time now is 07:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration