LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-01-2010, 02:47 PM   #1
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: ubuntu 10.04 / Arch
Posts: 296
Blog Entries: 3

Rep: Reputation: 50
Broken Packages- can't be fixed.


I attempted to install the package kubuntu-desktop on my Ubuntu 9.10 system. I then decided I didn't want it so I used this command to get rid of it. It errored out, the output of which follows.
Code:
Building dependency tree       
Reading state information... Done
Package akregator is not installed, so not removed
Package libkdepim4 is not installed, so not removed
Package libkontactinterfaces4 is not installed, so not removed
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  avidemux-plugins: Depends: libqtcore4 (>= 4.5.1) but it is not going to be installed
                    Depends: libqtgui4 (>= 4.5.1) but it is not going to be installed
  gstreamer0.10-plugins-bad: Depends: libmodplug0c2 (>= 1:0.7-4.1) but it is not going to be installed
                             Depends: libmpcdec3 but it is not going to be installed
  libofa0: Depends: libfftw3-3 but it is not going to be installed
  libpolkit-gnome0: Depends: libpolkit-dbus2 (>= 0.7) but it is not going to be installed
                    Depends: libpolkit-grant2 (>= 0.7) but it is not going to be installed
                    Depends: libpolkit2 (>= 0.7) but it is not going to be installed
  mplayer: Depends: libaudio2 but it is not going to be installed
  mplayer-nogui: Depends: libaudio2 but it is not going to be installed
  pidgin-otr: Depends: libotr2 (>= 3.2.0) but it is not going to be installed
  scim: Depends: libscim8c2a (>= 1.4.9) but it is not going to be installed
  scim-bridge-agent: Depends: libscim8c2a (>= 1.4.9) but it is not going to be installed
  scim-gtk2-immodule: Depends: libscim8c2a (>= 1.4.9) but it is not going to be installed
  scim-modules-socket: Depends: libscim8c2a (>= 1.4.9) but it is not going to be installed
  wesnoth-data: Depends: ttf-dejavu but it is not going to be installed
  wine: Depends: libaudio2 but it is not going to be installed
  xscreensaver-data-extra: Depends: libjpeg-progs but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
sudo apt-get -f install also errors out as follows:
Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dvgrab libmpeg3cv lives-data libcvaux1 mplayer-skins mplayer akiradnews
  libweed0 frei0r-plugins ogmtools libgavl1 icedax libcv1 libhighgui1
  libquicktimecv optlibx11-noxcb-data libguicastcv mkvtoolnix
  optlibx11-noxcb-6 libebml0 libmatroska0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libkdepim4 libkontactinterfaces4
The following NEW packages will be installed:
  libkdepim4 libkontactinterfaces4
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
10 not fully installed or removed.
Need to get 0B/505kB of archives.
After this operation, 1,786kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
E: Invalid archive signature
E: Prior errors apply to /var/cache/apt/archives/libkdepim4_4%3a4.3.2-0ubuntu6_i386.deb
E: Invalid archive signature
E: Prior errors apply to /var/cache/apt/archives/libkontactinterfaces4_4%3a4.3.2-0ubuntu6_i386.deb
debconf: apt-extracttemplates failed: Bad file descriptor
dpkg-deb: `/var/cache/apt/archives/libkdepim4_4%3a4.3.2-0ubuntu6_i386.deb' is not a debian format archive
dpkg: error processing /var/cache/apt/archives/libkdepim4_4%3a4.3.2-0ubuntu6_i386.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
dpkg-deb: `/var/cache/apt/archives/libkontactinterfaces4_4%3a4.3.2-0ubuntu6_i386.deb' is not a debian format archive
dpkg: error processing /var/cache/apt/archives/libkontactinterfaces4_4%3a4.3.2-0ubuntu6_i386.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libkdepim4_4%3a4.3.2-0ubuntu6_i386.deb
 /var/cache/apt/archives/libkontactinterfaces4_4%3a4.3.2-0ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Can you help me fix the packages and get my system back to normal?
EDIT: apt-get doesn't want to do anything at all until this is fixed.

Last edited by Bratmon; 01-01-2010 at 02:50 PM.
 
Old 01-01-2010, 02:58 PM   #2
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: ubuntu 10.04 / Arch
Posts: 296
Blog Entries: 3

Original Poster
Rep: Reputation: 50
I think I fixed it by using apt-get clean
 
Old 01-01-2010, 03:30 PM   #3
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: ubuntu 10.04 / Arch
Posts: 296
Blog Entries: 3

Original Poster
Rep: Reputation: 50
Yeah, it's working fine now. I believe it might have been a corrupt download or something.
 
  


Reply

Tags
apt


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken packages (openoffice) can't get them fixed (AMD64) twinkers Debian 5 06-09-2009 10:11 AM
Broken packages hraposo Debian 2 08-13-2006 01:55 PM
intel pro wireless 2200 ipw2200 firmware broken and fixed lblisters Linux - Wireless Networking 2 02-11-2006 11:51 PM
Broken Packages hongman Linux - Software 2 04-13-2005 05:48 AM
fixed 3C905 broken ethernet Mandrake 10 Mugatu LinuxQuestions.org Member Success Stories 4 08-17-2004 12:15 AM


All times are GMT -5. The time now is 08:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration