LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-03-2005, 02:51 PM   #1
none1983
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Mandrake 10.1
Posts: 7

Rep: Reputation: 0
mandrake


I just installed mandrake 10.1 on my computer and everything went well until I tried login in for the first time. It's just loads into "dos" mode even once I've logged in. Did I mis select an option? What can I do the see the graphic side of Mandrake?

thanks,
Kristopher
 
Old 08-03-2005, 03:03 PM   #2
fishpi
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Rep: Reputation: 0
Are there any error messages displayed? Does anything seem out of place on startup? It sounds obvious, but did you leave the Mandrake CD in the drive when you rebooted after installing?

If there's nothing apparently wrong (apart from booting in text mode), what happens if you type 'startx' at a prompt after you log in?
 
Old 08-03-2005, 03:25 PM   #3
none1983
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Mandrake 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
there seem to be a few errors after typing startx.
-----
Failed to load /usr/x11r6/lib/modules/fonts/libfreetype.so
Failed to load "freetype" (loader failed, 7)
Failed to load /usr/x11r6/lib/modules/extensions/libglx.a (once-only module, 7)
Could not init font path elemnet unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

please consult the The x.org Foundation support at hhtp://wiki.x.org for help.
please also check the log files at "/var/log/xorg.0.log" for additional information.

XI0: fatal I0 error 104 (connectin reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.
-----

There seem to be the same problem is i try to login as Root. I had this OS installed before but removed it to test out the new Windows Vista. I'm pretty sure the files on the cd aren't corrupted seening they worked before.


thanks,
Kris

Last edited by none1983; 08-03-2005 at 07:51 PM.
 
Old 08-04-2005, 11:08 PM   #4
none1983
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Mandrake 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
booting problem

I just installed mandrake 10.1 on my computer and everything went well until I tried login in for the first time. It's just loads into "dos" mode even once I've logged in. Did I mis select an option? What can I do the see the graphic side of Mandrake?

this is what i get after typing startx.

-----
Failed to load /usr/x11r6/lib/modules/fonts/libfreetype.so
Failed to load "freetype" (loader failed, 7)
Failed to load /usr/x11r6/lib/modules/extensions/libglx.a (once-only module, 7)
Could not init font path elemnet unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

please consult the The x.org Foundation support at hhtp://wiki.x.org for help.
please also check the log files at "/var/log/xorg.0.log" for additional information.

XI0: fatal I0 error 104 (connectin reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.
-----

thanks,
Kristopher
 
Old 08-05-2005, 04:31 AM   #5
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Here are some commands you probably need to run and see their output:
first su - and type your root password
then
ls -l /usr/x11r6/lib/modules/fonts/ - look if there is a libfreetype.so module file
ls -l /usr/x11r6/lib/modules/extensions/ - and libglx.a module
tail -50 /var/log/xorg.0.log - and see something that can help you to localize problem
 
Old 08-05-2005, 05:31 AM   #6
runlevel0
Member
 
Registered: Mar 2005
Location: Hilversum/Holland
Distribution: Debian GNU/Linux 5.0 (“Lenny”)
Posts: 290

Rep: Reputation: 31
Re: booting problem

Quote:
Originally posted by none1983
I just installed mandrake 10.1 on my computer and everything went well until I tried login in for the first time. It's just loads into "dos" mode even once I've logged in. Did I mis select an option? What can I do the see the graphic side of Mandrake?

this is what i get after typing startx.

-----
Failed to load /usr/x11r6/lib/modules/fonts/libfreetype.so
Failed to load "freetype" (loader failed, 7)
Failed to load /usr/x11r6/lib/modules/extensions/libglx.a (once-only module, 7)
Could not init font path elemnet unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

please consult the The x.org Foundation support at hhtp://wiki.x.org for help.
please also check the log files at "/var/log/xorg.0.log" for additional information.

XI0: fatal I0 error 104 (connectin reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.
-----

As this is Mandriva you surely won't have to work a lot to fix the problem. Seems that the GLX driver isn't installed (the font error is not what causes the server to crash, it's a little bug in the X).

Anyway, the cause is some random weirdness during install. I don't know if you checked the md5sums in case you downloaded the ISO.

Normally the fat and dirty way to solve these problems is very simple:

Boot into the cdrom as if you where to install. Choose "update" instead of "Install", go thru the process and if asked install a package or two of your liking to ensure the database will be rebuild. Go through the update process and be specially carefull during X system setup. Reboot and you should be done.

If this doen't work just ask again and we will try to fix it the satandard way: Editing configs
 
Old 08-05-2005, 09:22 AM   #7
none1983
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Mandrake 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
I tired installing using the update option but it doesn't give me the option to install addition packages. The two files, libfreetype.so and libglx.a are both in there directory. The Xorg.0.log is pages long and i'm new at linux which doesn't help either.

I also tried the install option and that didn't help either. Can I just download the newer version of Xorg 6.8.2 ? How do you install gz or tar in ternimal?

Thanks,
Kristopher

Last edited by none1983; 08-05-2005 at 09:49 AM.
 
Old 08-05-2005, 02:45 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
I have merged the 2 threads. In future, do not post the same thread in your more than one place.
 
Old 08-05-2005, 06:40 PM   #9
none1983
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Mandrake 10.1
Posts: 7

Original Poster
Rep: Reputation: 0
I figured out the problem. During the installation of Mandrake 10.1 it gives an error saying it can't install xorg 6.x.x but i just clicked to continue anyways. I'm going to redownload it again and try.

thanks for you reply,
Kristopher
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
booting problem hari78 Linux - Newbie 1 09-22-2005 02:59 PM
booting problem mare Linux - Software 6 09-02-2005 01:06 PM
booting problem einstien Linux - Hardware 1 07-06-2005 06:20 AM
Problem at booting satimis Linux - Hardware 2 04-10-2005 08:36 PM
problem booting up TallAmericano Mandriva 2 10-08-2003 02:42 PM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration