LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-31-2002, 04:09 PM   #1
elist
Member
 
Registered: Dec 2001
Location: MK - UK
Distribution: Mandrake
Posts: 94

Rep: Reputation: 15
booting - modules errors


Can someone tell me how to get rid of these. I got them when I tried to install lm_sensor modules.

Jan 31 21:45:57 panza depmod: depmod:
Jan 31 21:45:58 panza depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/adm1021.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/adm9240.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/bt869.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/eeprom.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/gl518sm.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/gl520sm.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/lm75.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/lm78.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/lm80.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/ltc1710.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/matorb.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/maxilife.o

Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/sis5595.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/thmc50.o
Jan 31 21:45:58 panza depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.8-26mdk/misc/w83781d.o
Jan 31 21:45:58 panza rc.sysinit: Finding module dependencies: failed
Jan 31 21:45:58 panza : Loading module: scsi_hostadapter
 
Old 01-31-2002, 04:58 PM   #2
elist
Member
 
Registered: Dec 2001
Location: MK - UK
Distribution: Mandrake
Posts: 94

Original Poster
Rep: Reputation: 15
I think it might be fixed, I just removed all the .o files listed. Ran depmod from shell and no errors.
 
Old 01-31-2002, 05:11 PM   #3
isajera
Senior Member
 
Registered: Jun 2001
Location: San Antonio, TX
Distribution: distro? what's a distro?
Posts: 1,635

Rep: Reputation: 45
well... that's one way to do it. an error like that is usually produced when the kernel headers you have on your system aren't the same version as the running kernel. if you've recompiled your kernel or updated it, you might want to check the symlinks in /usr/src/linux and /usr/include/linux
 
Old 02-01-2002, 04:54 AM   #4
elist
Member
 
Registered: Dec 2001
Location: MK - UK
Distribution: Mandrake
Posts: 94

Original Poster
Rep: Reputation: 15
I haven't recompiled.
Because it's just a default mandrake install, I think I've got 2 kernels there. One is 2.2.somethingidontknow and the other is 2.4.8.26. The one I'm running is 2.4.8.26. I haven't recompiled any kernel (Oh imagine the mess I'd make of that), and the modules listed in the error are in a directory under the correct kernel number.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Modules: errors in logs LadFromWales85 Slackware 4 07-28-2004 05:10 AM
modules.conf errors doralsoral Linux - Software 1 05-11-2004 10:03 PM
make modules errors out zmanea Linux - Newbie 2 02-26-2004 08:54 AM
recompiled kernel -> modules errors maciek Linux - Software 2 01-09-2004 01:34 PM
Module Errors with no modules used? mikeyt_333 Linux - General 4 02-02-2002 10:31 PM


All times are GMT -5. The time now is 04:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration