LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-18-2002, 05:32 AM   #1
acadcworks
LQ Newbie
 
Registered: Oct 2002
Posts: 21

Rep: Reputation: 15
Booting into Single User on MDK 9 asks for root password instead of booting into root


I have been able to run single user mode of mandrake 9. However, it then asks during the boot to enter root password for maintenance mode. This is what I am trying to change cos I forgot it! Everyone says you are supposed to get into root prompt in single user mode but it doesn't look this way.

Am I missing something?
 
Old 12-18-2002, 05:55 AM   #2
rootboy
Member
 
Registered: Oct 2001
Distribution: Mint 15
Posts: 770

Rep: Reputation: 51
Here is the "traditional" help:

http://www.linuxmanagers.org/piperma...ry/000322.html


Did you do this? Note that typing "linux 1" isn't quite the same as working within the repair mode (so try "linux 1" or "linux single" at your lilo prompt).

Some lilo configurations have this disabled via a lilo password. You don't, it appears.


And since you are probably using grub instead of lilo:

http://www.linuxselfhelp.org/phpBB/v...=202&forum=3&2

Here's the gist of it:

Quote:
When GRUB boots up, select the version of the kernel that you wish to boot and type e for edit. You will be presented with a list of items in the configuration file for the title you just selected.

Select the line that starts with kernel and type e to edit the line.

Go to the end of the line and type single as a separate word (press the [Spacebar] and then type single). Press [Enter] to exit edit mode.

Back at the GRUB screen, type b to boot into single user mode.

And, here's my google in case you need it:

http://www.google.com/linux?hl=en&lr...+mandrake+grub


John
 
Old 12-18-2002, 06:50 AM   #3
acadcworks
LQ Newbie
 
Registered: Oct 2002
Posts: 21

Original Poster
Rep: Reputation: 15
i'm using LILO. And following just about every tutorial anyone throws at me does not work.

linux 1

does not work because it prompts for a root password

the passwd entry for root does not have a password in it so that does not reset anything

linux init=/bin/sh

does get me to a prompt but I cannot see passwd command even when I mount everything.
 
Old 12-18-2002, 07:52 AM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,175

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Try this:
Use your 1st install CD and boot to rescue mode then
Edit your /etc/passwd file
root:x:0:0:root:/root:/bin/bash <-change this
root::0:0:root:/root:/bin/bash <- to this
Then you can reboot and login as root without a password.
 
Old 12-18-2002, 08:26 AM   #5
acadcworks
LQ Newbie
 
Registered: Oct 2002
Posts: 21

Original Poster
Rep: Reputation: 15
it is already this
 
Old 08-20-2003, 05:58 PM   #6
desrbd
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Rep: Reputation: 0
sorry but i cant post a new thread and i am hoping for some help!

Hi!
Ive gone through all the documentation i could find.. and i still cant get into run level 1 on my mandrake9 box (im a super newbie on linux)

Here is what happens on my machine...

when my computer starts up i get a graphic page with options:
linux-secure
linux-nonfb
failsaife

From what i have understood, i should go into "failsafe" and
this should happen:

"If the 'Linuxconf' administration suite is installed, it will be started in console mode upon reaching runlevel 1. You will be presented with a runlevel menu or the possibility to use 'Linuxconf' to do system maintenance tasks."
from: (http://www.mandrakeuser.org/docs/admin/arecov2.html)-----

But on every option i press i get a "root authentication required"
And when i quit the Linuxconf screen linux starts and i get prompted with a login.

Where am i suppose to type in 'linux single' or 'init 1' ??
I dont get any prompt ever :/

(i have no recovery cd or floppy)

ive spent 5 hours now reading through documentations and forum answers and other help pages.. so i hope someone here can tell me if i should give or if there is anything i can do though i am very very bad linux.

thanks in advance!
 
Old 01-10-2006, 07:51 AM   #7
dev_rhce
LQ Newbie
 
Registered: Sep 2004
Posts: 9

Rep: Reputation: 0

Try This,

at boot prompt

linux init=/bin/sh

than at # promp do as per following,

fdisk -l
check your root partition and then

mount -o remount,rw /dev/hda1 /

than

passwd root
than give new password this will surely work.

ok.

Devang Shah
MCP,CCNA,RHCE.OCP
www.linuxcops.com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Preventing Linux from booting in Single User Mode LinuxSeeker Linux - Security 8 08-28-2009 08:12 AM
How could normal user obtain root password or change root password ckamheng Debian 18 02-18-2009 11:28 PM
single user mode while booting ravikumarG AIX 4 08-17-2005 02:57 AM
Disabling single user when booting carcassonne Linux - Security 6 07-21-2005 03:55 PM
Redhat 8 asks for root password before dialling head8k Linux - Newbie 9 02-21-2003 05:52 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration