LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-05-2002, 04:26 PM   #1
heather_k
LQ Newbie
 
Registered: Jun 2002
Posts: 2

Rep: Reputation: 0
Unhappy boot stops at "enable swap space"


I recently had an unexpected power outage and now my redhat 7.2 server won't boot. It's stops after "enable swap space [ok]". I'm new to linux, so I'm not sure what to do. Any suggestions?

Oh, also, I don't have a boot disk.....
 
Old 06-05-2002, 04:49 PM   #2
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Snag an install CD of a distro, or maybe tomsrtbt. If its a distro CD, usually CTRL+ALT+F2 will get you to a shell. Boot the machine with that, mount your linux partition manually (if your root RH partition is ext3, then Tom's rtbt won't cut it), and then run mkswap on the swap partition. Its odd that a swap partition was corrupted, but it can happen. If that doesn't work... do all of the same, but instead edit that partition out of /etc/fstab. That should at least allow your system to boot long enough to re-format that whole puppy... or you can just run without a swap partition... not necessarily dangerous, just not very stable either.

If you need any more specifics to that, just post back,

Cheers,

Finegan

Last edited by finegan; 06-05-2002 at 04:50 PM.
 
Old 06-06-2002, 03:12 PM   #3
heather_k
LQ Newbie
 
Registered: Jun 2002
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for the advice! I tried that out, but no go. I had a Linux guru come and take a look at it and he decided that fixing it would be more trouble than it's worth, so I guess I'm just going to start over. Bummer......
 
Old 06-06-2002, 03:36 PM   #4
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
but try to boot with rh72 boot cd and do linux rescue
and once in sytem do mkswap /dev/hdaX
swapon

good luck
 
Old 06-06-2002, 09:03 PM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
finegan, wouldn't the message, "enable swap space [ok]", get printed out after the swap space was successfully enabled? So, it would be what came next that's the problem.
 
Old 06-07-2002, 03:56 AM   #6
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
linuxcool is right
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 3 hangs on "Enabling swap space" tewald Fedora - Installation 16 04-14-2010 08:56 AM
Fedora 3 boot hangs after "Enabling swap space: [OK]" Voroojack Fedora 2 11-29-2005 09:21 AM
boot stops at "Updating module dependencies for 2.4..." everal Slackware 3 10-08-2005 01:55 PM
FC2 1.521 hangs after "enabling swap space" Oxxide Fedora - Installation 2 10-30-2004 05:19 PM
Sony Vaio PCG-NVR23 Booting FC2, hangs after "Enabling Swap Space" mgargiullo Fedora 1 09-08-2004 09:47 AM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration