LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-09-2007, 03:31 PM   #1
dh4
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Rep: Reputation: 0
boot hangs at the "/boot: clean" step


I'm having some issues with my Linux. I have had Fedora Core 5 installed for many months and it's not a configuration issue with my system.

The system was restarting from hibernation and it lost power causing a forced shutdown. Now when I try to boot it up it goes into a boot clean but it hangs at the:

/boot: clean xxx/yyyy blocks

stage. Is there anything that I can do to get it past this step?

Thanks to anyone out there who can help. I REALLY don't want to reinstall and reconfigure everything.
 
Old 03-10-2007, 11:14 AM   #2
dh4
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Smile problem fixed

Turns out that it was a problem with a FAT32 partition on my system that was in the /etc/fstab table. When I interrupted the boot sequence with <crtl>-c and got to a console I was able to fix the problem. I ran

fsck /dev/hda3

(the FAT32 partition) and it hung ... EUREKA! So I now knew that it was probably that partition that was a problem. I had to remount / as rw using:

mount -o remount,rw /

so that I could modify the /etc/fstab file.

Once I removed the FAT32 mount point the boot went fine.

Thanks to anyone who read this post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hangs on boot at "Starting hotplug subsystem: pci" pengu Debian 2 01-17-2007 11:52 PM
Fedora 3 boot hangs after "Enabling swap space: [OK]" Voroojack Fedora 2 11-29-2005 10:21 AM
Boot now Hangs @ "GRUB" How do I find Stage 2's Address??? Supafast Linux - Hardware 1 07-06-2005 10:55 PM
Suse 9.2 boot hangs at "setting up cmos clock" villinux Linux - Software 2 03-19-2005 04:02 AM
Mandrake 9.0 hangs on boot at "checking distribution dependencies" patpawlowski Mandriva 1 02-02-2004 06:01 AM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration