LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-21-2007, 08:36 PM   #1
linuxbird
Member
 
Registered: Feb 2006
Distribution: Slackware
Posts: 290

Rep: Reputation: 20
Boot Fails on Dual Boot Slackware 12


I have a system which is failing to boot a new installation of Slackware 12. I'm using lilo.

/dev/hda1 old linux root partition (Slack 11)
/dev/hda2 swap
/dev/hda3 new linux root partition (Slack 12)

Boots using LILO with /dev/hda1 just fine.

Boots using LILO with root=/dev/hda3 and hangs at "freeing unused memory"

It appears to be the new kernel which is having the problem loading, but I can load the same kernel from a DVD OK.

Searching, I find that this could be swap, initrd, and other things. So far I haven't found a solution.

I'm open for pointers.
 
Old 11-22-2007, 12:40 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Please post the output of:
fdisk -l
df -hT
cat /etc/lilo.conf
 
Old 12-26-2007, 08:24 AM   #3
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
If you don't give the add'l info. we ask for, we can't help.
 
Old 07-20-2008, 03:08 PM   #4
linuxbird
Member
 
Registered: Feb 2006
Distribution: Slackware
Posts: 290

Original Poster
Rep: Reputation: 20
This turned out to be a hardware problem. I had a disk which was bad, even though diagnostics told me it was OK. I imaged it to another drive, and everything worked OK. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub fails on ubuntu 5.10 dual boot xp due to sda webhideout Ubuntu 2 10-08-2005 04:55 PM
Grub - dual boot fails on sdb mhoma Linux - General 0 06-13-2005 11:08 AM
system alarm on boot in slackware 10.0 but not win2000(dual boot) Arch Stanton Slackware 3 01-24-2005 10:33 AM
GRUB dual boot with two diff kernels fails at boot mosquito_dk Linux - Software 3 09-06-2004 09:18 AM
slackware fails to boot didgameta Slackware 4 06-06-2004 12:34 PM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration