LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-21-2012, 01:34 AM   #1
useless_s_grant
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Rep: Reputation: Disabled
BIOS won't load Grub2 with GPT -- Troubleshooting Advise??


I just put a new arch install on a del xps13 ultrabook. No Matter what I do I cannot get grub to start after the bios loads. I am using GPT partition table and I left a 1MB gap and 2MB unformatted partition with the grub_bios flag set at the front of the drive. I'm wondering if my BIOS just doesn't support GPT partition tables? I'm using Dell Dell XPS L321X System BIOS Revision A04. Here is a dump of partition table and grub info:

http://pastebin.com/Y3qB437z

I'm not really sure where to go from here or what steps would be next in trouble shooting this problem. Can anyone take a look at some of these configs ^^ and tell me if im missing something easy? What should I do from here?

There is a bios upgrade availible but it doesn't look like it has anything to do with GPT.
 
Old 09-21-2012, 06:46 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,447

Rep: Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069
Why gpt ? - if it hurts don't do it . If it's for learning, I guess it's been a success of sorts.
I presume you followed the (generally excellent) Arch wiki. I would be guessing you didn't do the grub-install (as well).
 
Old 09-24-2012, 01:36 PM   #3
useless_s_grant
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
Why gpt ? - if it hurts don't do it . If it's for learning, I guess it's been a success of sorts.
I presume you followed the (generally excellent) Arch wiki. I would be guessing you didn't do the grub-install (as well).
Nothing about this is useful. I didn't ask if I should be using GPT. I didn't ask if I should read the un-linked aforementioned Arch-wiki article, (The article sucks BTW). And a quick glance at the info I provided in a paste bin would show that grub was installed to the MBR.

Dell Support Confirms the BIOS won't boot a GPT Partition Table.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub2 won't load Windows XP dhruvats Ubuntu 13 05-28-2013 12:42 PM
[SOLVED] Grub2 does not boot with GPT gldearman Linux - Software 1 07-02-2012 08:47 PM
[SOLVED] Grub2 won't load some OS's after expanding partitions slacker_et Linux - Virtualization and Cloud 12 04-04-2011 08:08 AM
Troubleshooting grub2 boot problem dbuehler Linux - Newbie 18 07-26-2010 09:06 PM
old BIOS (1992) won't detect my cdrom drive; BIOS says: neither IDE prots enabled carbono Linux - Hardware 5 05-18-2004 12:07 PM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration