LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-17-2006, 05:45 AM   #1
cap_ahab
LQ Newbie
 
Registered: Dec 2005
Posts: 15

Rep: Reputation: 0
/bin/bash: bad interpreter: Permission denied


Dear all,

due to lack of room on one of my partitions, I moved the user directiory to another partition and connected the user directory with a symbolic link from /home/user to the final destination. Everything worked fine so far, however now I wanted to run a script which does not work anymore. Here the error message:
bash: ./AIR_lin_script.sh: /bin/bash: bad interpreter: Permission denied
However, if I move the directory back to /home, the script runs.
What adjustments do I need to do in order to make it work also on the other partition?
Thank you very much for your help,

ahab
 
Old 01-17-2006, 07:08 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,459

Rep: Reputation: 352Reputation: 352Reputation: 352Reputation: 352
Are the filesystems different (ext2fs, fat, ...) between both directories ?
 
Old 01-17-2006, 07:14 AM   #3
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Maybe you are trying to run a script on a partition that has the "noexec" option on the filesystem.
Code:
cat /etc/mtab
To reenable it for the partition, change in /etc/fstab the noexec to exec.
 
Old 01-17-2006, 07:53 AM   #4
cap_ahab
LQ Newbie
 
Registered: Dec 2005
Posts: 15

Original Poster
Rep: Reputation: 0
solved

Dear nx5000,

thanks for the hint, you brought me on the right track. I changed my /etc/fstab entry for that partition to defaults, and it worked. This changed /etc/mtab permanently, and you were right, it did read noexec. I figured out that changing /etc/mtab will not give the desired results, and in addition, it will fall back to its initial entry after reboot.
Thanks again,

ahab
 
Old 01-17-2006, 08:11 AM   #5
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
mtab is maintained by mount and umount. It's just a list of the drives that are currently mounted. That's why after a reboot changes are lost.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/usr/bin/env: bad interpreter: Permission denied Master Fox Linux - Software 8 02-09-2012 08:25 AM
/bin/sh: bad interpreter: Permission denied njbrain Slackware 10 04-26-2010 11:46 AM
/bin/sh: bad interpreter: Permission denied itsaso Linux - Newbie 6 05-18-2005 10:00 AM
Selinux, ./INSTALL: /bin/sh: bad interpreter: Permission denied TomF Linux - Security 2 12-08-2004 11:36 AM
/bin/sh: bad interpreter: Permission denied linmix Linux - Software 12 08-16-2004 06:40 AM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration