LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-21-2008, 08:02 PM   #1
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Rep: Reputation: 15
Bad video playback in Ubuntu


When watching videos in VLC playback is not smooth. There is a thin horizontal line that flashes through the center of the screen. It usually happens during bright or fast-paced action scenes. It almost looks like a screen refresh problem but I don't think it is. Thats as best as I can describe it. It's watchable but very irritating. It is not a problem with VLC because every video player dose the same thing. I don't think its a codec problem (though it my be) because I see a similar issue with certain screen savers. I have a e-GeForce GS PCI Express Nvidia Card using the NVIDIA accelerated graphics driver (latest cards). Has anyone else seen this problem? is it a driver issue? is there a solution? I currently watch videos on Win XP and I want to abandon XP.

Thanks in advance.
 
Old 01-23-2008, 07:46 AM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Are you using compiz ("Desktop Effects")? This is a common problem with gl-accelerated applications on top of compiz because compiz and the application are effectively "competing" for the screen resources. Check and see if VLC provides an output plugin selection in its preferences. If so, try x11 or xv. (It's probably set to gl or gl2 right now).
 
Old 01-23-2008, 09:09 AM   #3
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Thank you.

Thank you Matir

This seems to work. I changed from default output to XVideo extension and it's working great. Indecently I thought after reading your post that disabling desktop effects would solve the problem (who needs bouncy windows anyway? :P). But when I did all VLC playback was sound and a green screen. odd eh? anyway, the Xvideo extention output works great in full screen but keeps the unsightly horizontal line in the small window view.

Thanks again
 
Old 01-23-2008, 09:31 AM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
The horizontal line is odd. Out of curiosity, do other players exhibit the same behavior?
 
Old 01-24-2008, 08:14 AM   #5
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Yes absolutely. I see it in screen savers, video players, streaming video from Firefox, even VLC still but only in a window view it is working perfect in full screen mode now.

thanks
 
Old 02-29-2008, 06:13 PM   #6
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Original Poster
Rep: Reputation: 15
It's back

Hello again. I am having the same problem again using the XVideo output. I have installed and enabled Compiz which it likely the source of the trouble. But disabling Compiz is not fixing the problem nor do I want to have to turn off desktop effects just to watch a movie. Also note that VLC is playing files fine under KDE so why not Gnome? any thoughts? the symptoms are the same as explained in my first post.
 
Old 02-29-2008, 06:20 PM   #7
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Correction.

sorry guys. I just tried again and disabling compiz dose fix the problem. But I don't want to disable my fun desktop just to watch a movie. Is there a way to get smooth playback with compiz enabled? let me know thanks.
 
Old 02-29-2008, 06:22 PM   #8
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
OpenGL

Have you tried using the opengl driver for movies. Might also try re-installing the codex.
 
Old 03-01-2008, 11:45 AM   #9
arthur42dent
LQ Newbie
 
Registered: Nov 2007
Posts: 24

Original Poster
Rep: Reputation: 15
opengl crashes

"Have you tried using the opengl driver for movies. Might also try re-installing the codex."

Yes I have tried the opengl output and VLC just crashes (program terminates not freezes). As far as the codex I am using ether w32codecs or gstreamer I'm not sure which. How can I make the opengl output work?
 
Old 07-18-2010, 06:35 PM   #10
erossmith
LQ Newbie
 
Registered: Jul 2010
Posts: 4

Rep: Reputation: 0
Bad video playback in Ubuntu

I am having the same video playback issue. The video looks like it "breaks" forming lines in the image; happens mostly when there is fast movement in the video.
 
Old 07-18-2010, 08:42 PM   #11
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
It is called screen tearing and it tends to result from poorly written GPU drivers.

A number of things you can do:
- specify refresh rates in your xorg.conf
- experiment with the v-sync option of the video card
- enable buffering in your video player

What I have found to be the most convenient, though, is using the vdpau video driver. No more tearing and it shifts the burden of playing video from the CPU to the GPU. Unfortunately, vdpau supports only nvidia cards released in the last three to four years.
 
Old 04-21-2011, 04:03 AM   #12
zephyr707
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
I am having this problem as well on ubuntu 10.10 with an nvidia 360m. I don't have an option for vdpau in VLC and have tried setting the "sync to VBlank" option in the nvidia X server settings panel. Playing around with various options in VLC still yields the tearing in full screen for me and it is frustrating...

I also have compiz, and have changed the refresh rate in the configuration from 50->60. Any other solutions to this problem?
thanks
 
Old 06-07-2011, 05:46 PM   #13
farmerluk
LQ Newbie
 
Registered: Jun 2011
Location: Dartford
Distribution: Xubuntu 11.10 64-bit
Posts: 9

Rep: Reputation: Disabled
I too am having this problem, which I didn't when running vista (changed about a week ago, loving it so much). Try as I can, the only thing I find makes a difference is maxing the buffer time, but it still happens. If it doesn't happen in other media players, I might consider dropping VLC after all these years.
 
Old 06-07-2011, 07:47 PM   #14
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 147Reputation: 147
Quote:
Originally Posted by zephyr707
Playing around with various options in VLC still yields the tearing in full screen for me and it is frustrating...
Try going into CompizConfig Settings Manager (Alt+F2, "ccsm"), going into the General Options, and in the Display Settings tab, uncheck "Unredirect fullscreen windows" (if not already unchecked). This should stop the media player from gaining direct screen access when you put it in fullscreen mode; Compiz will redirect content to an offscreen buffer first so it can blit it to the screen buffer at its own discretion, allowing for things like VSync etc. to work.

EDIT: damn, old thread…zephyr707/farmerluk just resurrected it. Nonetheless, the above advice should still apply.

Last edited by MrCode; 06-07-2011 at 07:52 PM.
 
Old 06-16-2011, 01:17 PM   #15
zephyr707
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
a fix that worked for me

the instructions in this post:

http://ubuntuforums.org/showthread.php?t=1021773

worked like a charm for me. no little tearing/ripping/flickering at all now during any scenes! hope it works for others!

peace
z
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
.WMV playback plays sounds but no Video on Ubuntu tarobs Linux - Desktop 5 08-29-2006 01:32 PM
video playback problems during fast video sequences atti Linux - Hardware 2 04-17-2006 03:50 AM
Video Playback-speeded up audio & video howone Suse/Novell 1 10-20-2005 01:24 AM
bad mpg video playback Lord Zoltar Linux - General 2 09-13-2004 10:18 PM
xmms cd playback bad tjpick Linux - Software 3 11-04-2003 01:05 PM


All times are GMT -5. The time now is 01:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration