LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-08-2009, 10:07 AM   #1
justemail
LQ Newbie
 
Registered: Apr 2009
Posts: 29

Rep: Reputation: 15
Red face Automount (NFS) is not working


I have worked on this problem for two days without success. Therefore now I am asking for HELP. I am testing to a real simple NSF Server/Client setup as follows:

---
NSF Client:
rs1.tib.com is the NFS Client running Apache Server & CentOS 5.3
eth0: 65.103.190.107 (Connects to the Internet)
eth1: 192.169.2.1 (Connect to NFS Server)

NFS Server:
ds1.tib.com is the NFS Server running CentOS 5.3
eth0: 192.168.2.100 (Connects to NFS Client rs1.tib.com)
---

To test this NFS Server/Client setup, I am trying to export WEB files from the NFS Server (ds1) to the Client (rs1).

---
The /etc/export on the NFS Server (ds1) looks like this:

/var/www/html 192.168.2.0/24(rw,fsid=0,insecure,sync,no_root_squash)

The /etc/auto.master on the NSF Client looks like this:
Note: Comment lines (#) are removed.
/misc /etc/auto.misc
/net -hosts
+auto.master
/- /etc/auto.tib

/etc/auto.tib looks like this:
/var/www/html -rw,fsid=0,sync,hard,intr ds1:/var/www/html
---

On NFS Server: nfs is running
On NFS Client: autofs, netfs, nfs are running
---

PROBLEM
When the NFS Client (rs1) BOOTS, nothing is mounted!!

HINT
On the NFS Client (rs1) I can manually mount the WEB files:

%mount t nfs4 ds1:/ /var/www/html

---

I believe there are one or two settings which I am not using correctly. I have tried various settings without avail. HELP!
 
Old 05-08-2009, 11:40 AM   #2
instrumentpilot
Member
 
Registered: May 2006
Posts: 31

Rep: Reputation: 2
justemail, I must confess I don't know what the /- does in the auto.master file, but I would be interrested in trying to change it to something like /tib so it reads

Code:
/tib /etc/auto.tib
Then try auto.tib puting this in auto.tib
/etc/auto.tib looks like this:
Code:
html -rw,fsid=0,sync,hard,intr ds1:/var/www/html

A "cd /tib/html" is what I'm suggesting as a try. If you can mount manually I'd assume nfs is fine.

Also, tail your /var/log/messages file on both systems to see if anything obvious shows up.

Other things that come to mind:
1) did you restart the autofs service?
2) rs1 does not already have a /var/www/html directory.
Keep us updated, I'm curious as to what this is and to learn what /- does.

Michael Cunningham
 
Old 05-08-2009, 11:56 AM   #3
justemail
LQ Newbie
 
Registered: Apr 2009
Posts: 29

Original Poster
Rep: Reputation: 15
I disabled the firewall on the NFS Server (ds1). Now the WEB folder/document are mounted on the NFS Client at BOOT time.

Previously, 'NFS4' was open on NFS Server (ds1). Does anybody has a solution? I don't want the FW to be left OPEN!
 
Old 05-08-2009, 02:26 PM   #4
justemail
LQ Newbie
 
Registered: Apr 2009
Posts: 29

Original Poster
Rep: Reputation: 15
Further investigation show that NFS4 has issues with the FW. I did a GOOGLE "NFS4 FW" and got lot of information. I don't want to mess around with FW so I am moving on. Thanks everyone for help.
 
Old 05-19-2009, 04:35 PM   #5
fbsmith
LQ Newbie
 
Registered: Mar 2005
Posts: 2

Rep: Reputation: 0
Automount

We had a similar problem.
It was fixed by adding a line that contained "sleep 30" as the second last line of the file /etc/init.d/network

Hope this helps you.
 
  


Reply

Tags
automount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with NFS automount deathsfriend99 Linux - Server 2 07-01-2008 08:37 AM
NFS and Automount athreyavc Linux - Server 4 12-10-2007 06:11 AM
automount nfs HA myutopia Linux - Networking 0 11-28-2006 11:06 AM
About NFS automount mahabooba Solaris / OpenSolaris 9 06-30-2006 12:31 AM
Automount NFS from LDAP info not working klnasveschuk Linux - Networking 2 07-26-2005 01:04 PM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration