LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-07-2003, 05:50 AM   #1
palanisaravanan
Member
 
Registered: Oct 2003
Location: India
Distribution: Debian
Posts: 95

Rep: Reputation: 15
Unhappy Automatic logout because of Idle time


hi!
I am using a Debian system.It got automatically logout,if there is no activity for 30 mts.I triend to set TMOUT value to -1.even after that the problem continues.In one thread I read that U have to edit the .bashrc file(in my root dir) and set the value of TMOUT there.but in my /root/.bashrc no values is set for TMOUT.After it logout the screen is blinking some times .
plz help me.
Thanks
 
Old 10-07-2003, 07:07 AM   #2
ne0mesis
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat 9
Posts: 5

Rep: Reputation: 0
try editing the file "profile" as in etc/profile

thats where you should find a tmout# in seconds value
 
Old 10-07-2003, 08:10 AM   #3
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Are you using the bash shell? (the default in debian)

If so, you can check the value of the TMOUT-variable by command
Code:
echo $TMOUT
If it is set, you can unset it by saying
Code:
unset TMOUT
To make the setting permanent, put that line into the "~/.bash_profile".

If the TMOUT-variable is not set, and it still kicks you out, you have some other problem.
 
Old 10-16-2003, 07:00 PM   #4
pavans
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Hi,
Could you stop xwindows from automatically logging you out. I am having the same problem.

When I do a ssh to the server , it does not log me out but when I am using xwindows, it logs me out after some idle time.

Any help?
Thnx
Pavan.
 
Old 10-17-2003, 10:51 AM   #5
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Is the TMOUT variable set? If it is, it can be in the ~/.xsession or similar file.

Other difference between login sessions and interactive sessions is that
the ~/.bashrc is invoked in non-login sessions and ~/bash_profile in login-sessions.
So the setting can be in the ~/.bashrc file or its global counterpart /etc/bash.bashrc
(doesn't exist in all distributions, but do exists in Debian).

See the invocation section in the bash manual page (man bash) for details.


Last edited by ToniT; 10-17-2003 at 10:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Logout after inactivity from KDE jst1 Linux - Newbie 2 02-23-2005 01:28 AM
logout gnome if the session is idle? yenonn Linux - Newbie 0 10-07-2004 12:35 AM
automatic logout every 10minutes Alien#007 Linux - Newbie 11 09-04-2004 02:51 PM
Automatic logout in Mandrake 9.1 (--T--) Mandriva 1 09-08-2003 09:08 AM
RH 7.2 Automatic Logout alanlq Linux - General 4 09-05-2002 02:38 PM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration