LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 05-06-2004, 05:12 PM   #1
rohan208
Member
 
Registered: May 2004
Posts: 75

Rep: Reputation: 15
AutoLogin in KDE/Gnome as "root" /redhat9


hello,
I have want to autologin into my redhat9 server as root, I can login as any other user by modifying the files "/etc/kde/kdm/kdmrc" or the gnome config file. But the gnome config doesnt not alow me to auto login as root?
I would like toe know whats a work around for it? i need tologin as root, an alternative i thought was to login as a user that has all root privilages, but i am not sure how that is done.
Any help is appriciated..
sincerely
Rohan
 
Old 05-06-2004, 05:17 PM   #2
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Create a user and add them to root group. I would advise against doing this...
 
Old 05-06-2004, 06:28 PM   #3
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
Thx for your reply,
I already tried doing that, I created a user, and made "root" as the users main group. How ever, this user could not access commands like "sudo" from the console, however the user could access various other GUI apps like users and groups manager etc... Any ideas how to get around this? Also what other approach is available if you do not recommond me to do that.

Thx
 
Old 05-06-2004, 06:33 PM   #4
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
You can always add * to the sudo list for that user. I would auto-login as a regular user and then su - when you need root access... It gives me the "willies" to know there is a super user always logged in.
 
Old 05-06-2004, 06:45 PM   #5
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
TheOther1, yes that "su" might work, but the system is fora mobile hotspot, so there wont be any user to "open console and type su", it needs to be done automatically and should give global access to all commands modules and configuraions. Would you know how to get that done?
I can think that i could add a script in my startup that does su, but i dont do scrupts much so dont knwo the syntax of it. So if i puti tall i nwords
- start pc
- autologin as regular user xyz
- open console
- su - root

now how do i do the last 2 parts automatically, so that when the user xyz logs in and gets su, he should be automatically ably to run anything on system

thx
 
Old 05-06-2004, 06:57 PM   #6
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Add any files you want them to run to sudoers file. See man sudo for details. I can't see why you would want to allow ANYONE to have root access. Why not just make the root password blank?
 
Old 05-07-2004, 10:47 AM   #7
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
AS TheOther1 said, you could leave the root password blank and edit /etc/sysconfig/autologin file to allow root as the prefered user
that path is from mandrake, maybe there's an equivalent in Redhat

Hope this helps
 
Old 05-07-2004, 11:08 AM   #8
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
thx Rockman and theother but Is there any other way than sudo or root pass blank?
What i really need to do is run the following bash script file
file name - test
content- ip route > filename.log
This needs to be done any time when a computer is rebooted. I thought auto logging in as a user and running the script file woulkd work. But the user cannot access the ip route command as he doesnt not have permissions. So how do i let sudo know that user rohan is alowed to access ip route command?
Thx
 
Old 05-07-2004, 11:41 AM   #9
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
sudoer file problem/redhat9

i have added the following line to the /etc/sudoers file

%xyz ALL=(ALL) NOPASSWD: ALL

doesnt that mean that any user in part of the goup xyz should be able to run all commands on the console?
Well i hava user xyz who is the part of group xyz, but he cant access the command "ip route" from the cshell. When i do su - root and then do ip route it works. any ideas how to get past this?
Rohan
 
Old 05-07-2004, 01:13 PM   #10
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Now we are getting somewhere. You want them to run ip route, correct? Try this:
chmod 755 /sbin/ip
chmod 755 /sbin/route
remove that stuff from sudo first. I thought you wanted them to be root equiv, not just for the above commands, but full-on god mode. There may be other dependencies you have to chmod also.
 
Old 05-07-2004, 01:24 PM   #11
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
Thx theother1, i tried
chmod 755 /sbin/ip
chmod 755 /sbin/route
i still cant do "ip route" from the username. I still get error

[xyz@Server1 ~]$ ip route
ip: Command not found.

when i do su to root user then ip route works fine..
anyideas how to get around this?

Thx..


ps: also how do i know what other modules need to be chmod755'd to get his to work?


Rohan
 
Old 05-09-2004, 05:34 PM   #12
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
^ bump
 
Old 05-27-2004, 01:21 AM   #13
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Since you changed the permissions on route (not a good idea), /sbin is not in the normal users path.
try
/sbin/route
To get sbin in your path add to ~/.bashrc
export PATH=$PATH:/sbin
 
Old 05-27-2004, 07:58 AM   #14
rohan208
Member
 
Registered: May 2004
Posts: 75

Original Poster
Rep: Reputation: 15
hey darthtux ..
thx for your reply.. that worked.
Rohan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can "root" unlock a locked screen in Gnome? AZ_Rider Linux - Newbie 5 11-30-2011 02:28 AM
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 05:08 PM
How to add Gnome style "drawer" (ie sub-menu) to KDE 3.1 kicker (aka KDE Panel) quaestor Linux - Software 7 10-17-2006 10:55 AM
Error launching gnome apps as root: " Failed to contact configuration server" Kropotkin Fedora 1 12-16-2005 12:11 PM
why does KDE shows only "Log out to Root " and Gnome has all options ? kishore_coolboy Linux - Newbie 2 03-11-2004 02:15 AM


All times are GMT -5. The time now is 11:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration