LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-11-2004, 03:31 PM   #1
agentforsythe
Member
 
Registered: Aug 2003
Location: Nottingham, UK
Distribution: Xandros, Debian, Solaris
Posts: 31

Rep: Reputation: 15
apt-get is broken, please help!


when I try to apt-get install anything:
Code:
dpkg: parse error, in file `/var/lib/dpkg/available' near line 2111 package `bfbtester':
 `Depends' field, reference to `libc6': version contains ` '
E: Sub-process /usr/bin/dpkg returned an error code (2)
any theories?
 
Old 01-11-2004, 05:12 PM   #2
phobox
Member
 
Registered: Dec 2003
Location: Columbus, OH USA
Distribution: Debian Knoppix Kanotix Sidux
Posts: 73

Rep: Reputation: 15
edit /var/lib/dpkg/available and remove lines that reference bfbtester
 
Old 01-11-2004, 05:21 PM   #3
phobox
Member
 
Registered: Dec 2003
Location: Columbus, OH USA
Distribution: Debian Knoppix Kanotix Sidux
Posts: 73

Rep: Reputation: 15
I think I wasn't very clear in my last post. Firstly, /var/lib/dpkg/available is a file that has entries for all the programs that dpkg has access to, with information about each file. Probably what happened is the entry for bfbtester got mangled, possibly some extra (illegal) characters were added. By removing the entry, or by finding the error on line 2111, your problem should be fixed.
 
Old 01-12-2004, 04:24 AM   #4
agentforsythe
Member
 
Registered: Aug 2003
Location: Nottingham, UK
Distribution: Xandros, Debian, Solaris
Posts: 31

Original Poster
Rep: Reputation: 15
thanks!

I'll give that a try when I get home
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken apt-get ebenh Debian 12 04-11-2012 01:36 PM
apt-get is broken irvken Linux - Software 3 12-12-2004 05:18 AM
apt-get seems broken jon_k Linux - Software 1 12-09-2004 07:20 PM
apt-get broken? limiter Linux - Software 4 03-21-2004 06:26 PM
broken apt-get mindcry Linux - Software 0 05-24-2003 10:55 AM


All times are GMT -5. The time now is 11:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration