LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Apache OS Threads, Error with libpthread.so.0? (http://www.linuxquestions.org/questions/linux-general-1/apache-os-threads-error-with-libpthread-so-0-a-514844/)

robinBones 12-30-2006 09:06 AM

Apache OS Threads, Error with libpthread.so.0?
 
am trying to get Roundup Issue Tracker, http://roundup.sourceforge.net/doc-1...-web-interface
running on my CENT server. In the install documents, it says that most apache installs are not built with OS threading, and require this threading library to be loaded.

LD_PRELOAD=/lib/libpthread.so.0
export LD_PRELOAD

After I run those commands, many shell commands such as ls, cp, and mv dont run. I get the following errors

ls: /lib/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /lib/tls/librt.so.1)

cp: relocation error: /lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

mv: relocation error: /lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

as far as I can tell, I am using glibc 2.3.4. Is there a package I can install to get a version of libpthread that will work with GLIBC 2.3.4?

btmiller 12-31-2006 06:24 PM

Why don't you use the Apache packages thatr come with CentOS? They will work. The site you have gives instructions for setting up that software with Apache and mod_python (or just by using cgis).

knurpsl 02-06-2007 02:05 AM

got the same problem

http://www.linuxquestions.org/questi...97#post2618297
let me know if theres news

knurpsl 02-06-2007 11:18 AM

not quite having figured out my problem.
there are probably various libpthread libs
in /lib

have you tried one of the other ones?


All times are GMT -5. The time now is 09:38 PM.