LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-10-2010, 02:52 AM   #1
Jeff91
Bodhi Developer
 
Registered: Jan 2009
Location: Alsip, IL
Distribution: Bodhi and Maemo
Posts: 300

Rep: Reputation: 33
(another) Issue compiling gnome-libs


I am trying to compile the gnome-libs package. However I am hitting the following error message at the at of the configure step:
Code:
*** Building HTML ***
test -d ./html || mkdir ./html
cd ./html && gtkdoc-mkhtml libart ../libart.sgml
/scratchbox/devkits/doctools/bin/openjade:../sgml/art_svp.sgml:68:10:E: end tag for "PARA" omitted, but OMITTAG NO was specified
/scratchbox/devkits/doctools/bin/openjade:../sgml/art_svp.sgml:67:0: start tag was here
/scratchbox/devkits/doctools/bin/openjade:../libart.sgml:851:2:E: cannot open "../fdl.sgml" (No such file or directory)
make[4]: *** [html-build.stamp] Error 1
make[4]: Leaving directory `/home/jeff91/gnome-games/gnome-libs-1.4.2/libart_lgpl/doc'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/jeff91/gnome-games/gnome-libs-1.4.2/libart_lgpl'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory `/home/jeff91/gnome-games/gnome-libs-1.4.2/libart_lgpl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jeff91/gnome-games/gnome-libs-1.4.2'
make: *** [all-recursive-am] Error 2
I have the following libart packages installed:
Code:
[sbox-FREMANTLE_ARMEL: ~/gnome-games/gnome-libs-1.4.2] > apt-cache search libart
libart-2.0-2 - Library of functions for 2D graphics - runtime files
libart-2.0-dev - Library of functions for 2D graphics - development files
libart2 - The GNOME canvas widget - runtime files
libart-dev - The GNOME canvas widget - development files
So I am not sure what packages I am missing - something involving html? Taking suggestions.

Thanks,
~Jeff
 
Old 01-10-2010, 07:13 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,919

Rep: Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586Reputation: 2586
May be : ./configure --disable-gtk-doc
.. as the file 'rules' says.

Reason : The files are dated 1999...2002 and the ancient
sgml tools to make the docs may no longer be available
on a modern system.

http://packages.debian.org/lenny/gnome-libs-data
> [gnome-libs_1.4.2-37.diff.gz]
> > http://ftp.de.debian.org/debian/pool...4.2-37.diff.gz

patch -p1 < gnome-libs_1.4.2-37.diff
.. and read ' gnome-libs-1.4.2/debian/rules '.

It is a very good idea always to apply the patch,
may fix some bugs, and show some special configure
options ... in 'rules'.
.....
 
Old 01-10-2010, 02:53 PM   #3
Jeff91
Bodhi Developer
 
Registered: Jan 2009
Location: Alsip, IL
Distribution: Bodhi and Maemo
Posts: 300

Original Poster
Rep: Reputation: 33
Ahh very good to know, I'll give that a try. Can you tell I am slightly new to building packages? Thanks for all your help/suggestions the last few days.

~Jeff
 
  


Reply

Tags
compiling, configure, gnome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help on where to get development libs and help on compiling in YDL 6.0 samool2 Linux - Newbie 1 06-13-2008 02:17 AM
Missing curl-libs compiling GRIP senorsnor Slackware 7 10-18-2004 10:54 PM
gnome-libs-devel... Linux~Powered Slackware 0 09-04-2004 08:01 PM
double compiling of certain libs ??????? tuxfood Programming 1 07-20-2004 09:06 AM
Problems compiling avview ... tcl libs aren't found |etnies| Linux - Software 0 05-16-2004 05:50 AM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration