LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-24-2008, 06:11 PM   #31
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45

I think it is X dependant only if I have the option that needs libnotify enabled. In fact I am pretty sure that is the case.
 
Old 04-17-2008, 09:55 PM   #32
kcoriginal
LQ Newbie
 
Registered: Oct 2007
Location: US -First Baltimore, then MD Sticks, then NC then Cali now San Antonio.
Distribution: ubuntu 8.04 and Centos 5.2
Posts: 29
Blog Entries: 4

Rep: Reputation: 15
"chmod" command...

This is one of the biggest frustrations of my Linux life!

scripts you create from scratch ALWAYS need to be made 'executable' in order for Linux to run them.

"chmod" is pretty easy to learn and is found in Chapter 2 of most Linux reference books...

...but, basically... 777 means setting Read/Write/and Execute for all users and groups of your system.

By default, newly created text files (aka newly created scripts...) have Read/Write persmissions set, but not Execute... I believe that equates to a chmod of 551

"chmod 777 hellanzb.py" (without the quotes, from inside the directory where the file is located) should do the trick... although... "chmod 751 hellanzb.py" or "chmod 711 hellanzb.py" is probably safest



God I hope this saves someone frustration... I would be LIGHT-YEARS ahead in learning Linux if I had found that sooner!
 
Old 05-03-2008, 08:20 PM   #33
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Your chmod anecdote is interesting. However hellanzb.py was always executable. Even as a normal user. See post 7 to see that it already has the executable attribute. The issue lay firmly with the fact that it needed an X environment to run due to one of the options I chose in its configuration.
 
Old 05-05-2008, 11:30 AM   #34
kcoriginal
LQ Newbie
 
Registered: Oct 2007
Location: US -First Baltimore, then MD Sticks, then NC then Cali now San Antonio.
Distribution: ubuntu 8.04 and Centos 5.2
Posts: 29
Blog Entries: 4

Rep: Reputation: 15
Quote:
Originally Posted by geniushasan View Post
Jongi
are u setting 777 i mean are u giving the executable permission ?
it needs to begin with S --> inorder to start
and then the process number -- > 97 for example | inorder to initiate the process with the priority as a number.


S97filename | make sure its 7xx


When you responded that you didnt have a clue what he was talking about here... I figured I would share this eureka moment... just in case!

regards

kc
 
Old 05-18-2008, 03:29 PM   #35
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So Debian doesn't have the folder /etc/X11/xinit/xinitrc.d/ . It does however have the file /etc/X11/xinit/xinitrc . So I thought adding the line /usr/bin/hellanzb -D to it would see it working. However the daemon does not start in Debian. Again the same command works from the command line once Debian is up and running.

Code:
[root:~#] locate hellanzb | grep bin
/usr/bin/hellanzb
/usr/share/python-support/hellanzb/Hellanzb/NewzbinDownloader.py
[root:~#] ls -la /usr/bin/hellanzb
-rwxr-xr-x 1 root root 1942 2008-01-05 01:04 /usr/bin/hellanzb
[root:~#] cat /etc/X11/xinit/xinitrc 
#!/bin/bash
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession

#HellaNZB
/usr/bin/hellanzb -D
sleep 10
There even wasn't a 10 second pause anywhere
 
Old 05-18-2008, 05:09 PM   #36
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Well, the script wouldn't get to your addition before the X session had terminated, eh? So you might see a 10 sec. delay before your logoff is processed/
 
Old 05-19-2008, 12:33 AM   #37
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
While I know they are not the same, in Sidux the exact same script worked. That is, the hellanzb process is running when X I am in an X session.
 
Old 05-19-2008, 06:05 PM   #38
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Added /usr/bin/hellanzb -D to ~/.xinitrc. No help. The most promising result was when I added the line to ~/.xsession. Except that it ignored the fact that the system is meant to auto login. And it came up with a different login screen. When I wen tto console from there, hellanzb was running. So it was close, close but no cigar.
 
Old 05-19-2008, 09:40 PM   #39
bsdunix
Senior Member
 
Registered: May 2006
Distribution: Caldera, CTOS, Debian, FreeBSD, Mac OS X, Mandrake, Minix, OpenBSD, Slackware, SuSE
Posts: 1,757

Rep: Reputation: 79
Quote:
Originally Posted by kcoriginal View Post
scripts you create from scratch ALWAYS need to be made 'executable' in order for Linux to run them.
This is not "ALWAYS" true. You can execute a script from the command line without the shebang command interpreter line at the top of the script and without executable bit set on the script file, but the calling command interpreter must preceed the script file name.
Code:
user@mybox:~$ cat /home/user/scriptfile
echo "This is a test"

user@mybox:~$ /bin/sh /home/user/scriptfile
This is a test

user@mybox:~$ /bin/csh /home/user/scriptfile
This is a test
 
Old 05-20-2008, 03:55 PM   #40
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
I also tried adding the line to /etc/X11/Xsession but that didn't work either
 
  


Reply

Tags
boot, daemon, hellanzb, startup


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i add a local Folder on local Hard Disk as Yum Repository ?? vahid_p Fedora 4 02-22-2007 11:43 AM
Roaming Profile Local Settings Folder missing Pinkks Linux - Networking 6 02-13-2007 03:33 PM
Setup local machine to allow lan machines to retrieve its local user mail. Brian1 Linux - Networking 3 03-30-2006 06:04 AM
Local webserver -- How to deny all client install their local web server--Please help b:z Linux - Networking 13 04-16-2005 08:11 PM
MySQL command prompt (/usr/local/mysql missing) sankar555 Linux - Software 3 03-22-2003 01:48 PM


All times are GMT -5. The time now is 04:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration