LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 10-10-2005, 09:14 PM   #1
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Rep: Reputation: 15
alsaconf doesn't detect my soundcard.


It seems that i'm missing some modules but i don't know what to do to fix it, or if that's even the specifcic issue. This is what I get out of the terminal (the parts in " " are in ncurses screens):

aopen25:~# alsaconf
modinfo: snd: no module by that name found
modinfo: snd: no module by that name found
modinfo: snd: no module by that name found

"You should stop all sound applications now" <Ok>

Unloading ALSA sound driver modules: (none loaded).
Building card database...

"No supported PnP or PCI card loaded.
Would you like to probe legacy ISA sound cards/chips?" <Yes> <No>

~
Now, i know that my two cards are "Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)" and "Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 09)", but that's about where my well of knowledge runs dry.

Edit:
Forgot to add that this is in Debian, if that makes a difference.

Last edited by Lokathor; 10-10-2005 at 09:22 PM.
 
Old 10-15-2005, 01:24 PM   #2
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Original Poster
Rep: Reputation: 15
bump

If no one knows how to do a workaround for alsa, does anyoen at least know how to do a manual sound setup?
 
Old 10-15-2005, 01:36 PM   #3
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,
what kind of kernel are you using? vanilla, self compiled or something else?
this is pretty weird. That message sounds like you have your card compiled as builtin in your kernel...
post the following output, please
Code:
grep -i snd /usr/src/$whatever_your_kernel_is_called/.config
regards,
slackie1000
 
Old 10-25-2005, 09:29 AM   #4
torsin
LQ Newbie
 
Registered: Oct 2005
Location: minnesota
Distribution: debian (sarge)
Posts: 15

Rep: Reputation: 0
similar problems

Hi, I'm also having problems with my sound card an Ensoniq es1371. I'm running Debian Sarge just as I downloaded. My output for
Code:
grep -i snd /usr/src/linux-2.4.27-2-386/.config
is:
Code:
CONFIG_SOUND_MSNDCLAS=m
# CONFIG_MSNDCLAS_HAVE_BOOT is not set
CONFIG_MSNDCLAS_INIT_FILE="/etc/sound/msndinit.bin"
CONFIG_MSNDCLAS_PERM_FILE="/etc/sound/msndperm.bin"
CONFIG_SOUND_MSNDPIN=m
# CONFIG_MSNDPIN_HAVE_BOOT is not set
CONFIG_MSNDPIN_INIT_FILE="/etc/sound/pndspini.bin"
CONFIG_MSNDPIN_PERM_FILE="/etc/sound/pndsperm.bin"
Thanks, Much
 
Old 10-26-2005, 12:42 AM   #5
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Original Poster
Rep: Reputation: 15
Sorry for not getting back to this. I was able to fix the issue with the help of this thread:

http://www.linuxquestions.org/questi...light=alsaconf

The medoth of uninstalling it and using the specific version listed worked well enough for me.

I was using the default kernel that comes with the Sarge CDs... I'd list the output of the command you gave, but with the problem fixed it's likely going to be useless. That... and I didn't make it myself, so there isn't even a folder for it, much less a config file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsaconf fails to detect motherboard sound card BuckRogers01 Debian 10 07-15-2005 04:43 PM
Audigy 2: No soundcard found...(alsaconf) Doergn Linux - Hardware 1 06-11-2005 03:46 PM
ALSACONF no detecting my soundcard Whatshisface Linux - Hardware 4 03-10-2005 11:24 PM
alsaconf doesn't detect my onboard soundcard ByteWarrior Slackware 3 04-06-2004 09:36 AM
alsaconf wont detect my sound card biophysics Linux - Hardware 22 07-22-2003 08:32 AM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration