LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-11-2002, 11:53 PM   #1
Tomasfuego
Member
 
Registered: Nov 2002
Location: USA
Distribution: Lenny at work
Posts: 168

Rep: Reputation: 30
ALSA 5.1 sound with intel8x0


//////////////////////
~~My Setup~~~
///////////////////////
RH 8 with the 2.4.18-17.8.0
Gigabyte GA-81GX motherboard which has the Intel 845G chipset.
Creative 5300 Speakers ( 5 satellites and a subwoofer)
i810 sound, using the ICH4 chip

my speakers are connected to the Line In, Line Out, and Mic In ports ( they are used as front, rear and center resp. during playback)

Results from "amixer":

Simple mixer control 'PCM',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]

Results from lsmod
Module Size Used by Tainted: P
snd-pcm-oss 44388 0 (autoclean)
snd-mixer-oss 15512 0 (autoclean) [snd-pcm-oss]
snd-intel8x0 23648 3 (autoclean)
snd-pcm 83232 0 (autoclean) [snd-pcm-oss snd-intel8x0]
snd-timer 15304 0 (autoclean) [snd-pcm]
snd-ac97-codec 35332 0 (autoclean) [snd-intel8x0]
snd-mpu401-uart 4812 0 (autoclean) [snd-intel8x0]
snd-rawmidi 18400 0 (autoclean) [snd-mpu401-uart]
snd-seq-device 6176 0 (autoclean) [snd-rawmidi]
snd 38892 6 (autoclean) [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]

Results from modules.conf (everyone asks for this):
# ALSA portion
alias snd-card-0 snd-intel8x0
#alias snd-card-0 snd-interwave
alias snd-card-1 snd-cmipci
options snd-cmipci snd_id="first" snd_enable_midi="1"
# OSS/Free portion - card #1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
# OSS/Free portion - card #2 (cmipci)
alias sound-slot-1 snd-card-1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :
post-install snd-card-1 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-1 /usr/sbin/alsactl store >/dev/null 2>&1 || :
///////////////////////////////
~~~ Current Status~~~
///////////////////////////////
installed alsa with the RPM packages from freshrpms. Sound works, can play xmms, xine and ogle using ALSA natively and through oss compatability

The center speaker sounds like an engine and makes noises when scroll pages or do other things. The center and LFE channels do squat on the alsamixer

My rear speakers make sound, but to hear them I have to unplug my fronts and turn the PCM and Master volumes all the way up
///////////////////////////////////////
~~~~My Question ~~~~~~~~
////////////////////////////////////////

Hardware wise:
How do i get the center to work and boost ( or control ) the rear speakers? Is it something a .asoundrc file could help? Im so clueless here

<<<Dont answer these, im just upset >>>>
Software wise:
Why does ALSA have barely ANYTHING RELEVANT on their website???? <==(Frustration from fruitless research)

Philosophically:
Why cant Sound card companies (i.e. Creative ) be as nice as the video card people ( i.e. NVidia ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA no sound intel8x0 Suse 9.2 Help chillz Linux - Hardware 5 12-11-2004 03:02 PM
Alsa so close yet so far (intel8x0) Zugwalt Linux - Hardware 1 10-21-2004 05:37 PM
ALSA and intel8x0 problem jcrcabre Linux - Software 3 05-09-2004 01:28 AM
no sound with ALSA, 2.6.1 kernel, intel8x0 (unmuted) hope Linux - Hardware 8 01-22-2004 04:06 AM
peculiar sound problem (MDK90, Intel8x0, ALSA) deputyjim Linux - General 3 11-26-2002 03:56 PM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration