LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-16-2003, 03:16 AM   #1
Sir Gawain
Member
 
Registered: Sep 2003
Location: Illinois, United States
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
Allowing non-root to use mounted partition


Ok, I have my 120gb hdb1 mounted as /fat-d in slackwar 9.1 and root can access everything fine, but my user account cannot view anything. I tried editing the permissions, but that didn't seem to help.

This is kinda annoying as I have to run XMMS as root if I want to play music or If I want to get my website stuff.
 
Old 10-16-2003, 03:20 AM   #2
septanla
Member
 
Registered: Sep 2003
Posts: 69

Rep: Reputation: 15
edit fstab file, add option umask=0
 
Old 10-16-2003, 03:58 AM   #3
Sir Gawain
Member
 
Registered: Sep 2003
Location: Illinois, United States
Distribution: Slackware 9.1
Posts: 37

Original Poster
Rep: Reputation: 15
/dev/hda6 swap swap defaults 0 0
/dev/hda7 / reiserfs defaults 1 1
/dev/hdb1 /fat-d vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

So where do I add umask=0?
 
Old 10-16-2003, 04:38 AM   #4
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
/dev/hdb1 /fat-d vfat user,umask=0 1 0
 
Old 10-16-2003, 04:50 AM   #5
Sir Gawain
Member
 
Registered: Sep 2003
Location: Illinois, United States
Distribution: Slackware 9.1
Posts: 37

Original Poster
Rep: Reputation: 15
Hmm... I can now see the base level directory (thank you), but cannot go into any of the folders for some reason. They show up as files and I cannot open them.

I can only get into the base dir using the gnome file manager (terminal and xfm give me permission errors still)
 
Old 10-16-2003, 05:19 AM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
You could always try:

/dev/hdb1 /fat-d vfat umask=000,defaults 0 0
 
Old 10-16-2003, 06:28 AM   #7
Sir Gawain
Member
 
Registered: Sep 2003
Location: Illinois, United States
Distribution: Slackware 9.1
Posts: 37

Original Poster
Rep: Reputation: 15
Nope.

What seems to be happening, is that only gnome can look into /fat-d but it cannot open anything inside of it because it have no idea what the files are.

But it all works file if I log into gnome as root.
 
Old 10-16-2003, 06:43 AM   #8
Rab22
Member
 
Registered: Dec 2002
Location: Currently: Normal, IL @ ISU -- Typically: South of Chicago
Distribution: Currently: RH 9 && Slackware 9.1 =)
Posts: 50

Rep: Reputation: 15
Try adding "user" to it. Simliar to this:

/dev/hdb1 /mnt/fat-d vfat auto,user,umask=0 0 0

See if that helps ya out
 
Old 10-16-2003, 09:37 AM   #9
fatgod
Member
 
Registered: Mar 2002
Location: Edinburgh, Scotland
Distribution: Suse 7.2, Gentoo 1.4, Solaris 9
Posts: 661

Rep: Reputation: 30
you can make all the files appear and behave as though they are owned by a specific user and group if you want to, and then make all files appear with certain permissions...

add to the options: gid=user,uid=root,fmask=640,dmask=750

I've got something like this on my samba shares that are mounted at boot, I reckon that these options will work for vfat too though.

Just something else for you to think about
 
Old 10-16-2003, 09:57 AM   #10
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Try adding umask=0222 to the options.

For my options for my windows partition, i have: noauto,ro,umask=0222

noauto means don't mount it at boot time
ro means mount it as read only
umask=0222 means the default permissions are read and execute for everyone (it takes 777 minus the umask, which in this case is 555 which means read/execute permissions)
 
Old 10-16-2003, 12:05 PM   #11
Edward78
Member
 
Registered: Jul 2002
Distribution: OpenSuSE 11
Posts: 441

Rep: Reputation: 30
Quote:
Originally posted by iainr
/dev/hdb1 /fat-d vfat user,umask=0 1 0
umask=0 0 0
 
Old 10-16-2003, 04:19 PM   #12
Sir Gawain
Member
 
Registered: Sep 2003
Location: Illinois, United States
Distribution: Slackware 9.1
Posts: 37

Original Poster
Rep: Reputation: 15
Still trying but the closest I get is still just getting unreconizable files.

EDIT: I found out that I needed to change umask=0 to MY umask and it works fine now.

Last edited by Sir Gawain; 10-16-2003 at 10:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
root partition cant be mounted Ashish Meena Linux - Newbie 5 08-23-2005 07:49 AM
Allowing port access to non-root joosep Linux - Networking 1 08-05-2005 09:24 AM
Allowing read/write on mounted captive-ntfs partition divsky Linux - General 6 04-15-2004 10:52 AM
Allowing root to use X indigojo_uk Linux - Distributions 3 12-19-2003 06:38 AM
I updated the system and now only root can see a mounted partition ganninu Linux - General 15 11-15-2003 03:30 PM


All times are GMT -5. The time now is 04:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration