LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   ADSL Router + Linux Router + LAN = HELP!!! (http://www.linuxquestions.org/questions/linux-general-1/adsl-router-linux-router-lan-%3D-help-92391/)

linuxlois 09-13-2003 11:57 AM

ADSL Router + Linux Router + LAN = HELP!!!
 
:newbie:

PROBLEM:

I have to connect a Lan (192.168.10.11/13) with a ADSL router (192.168.254.254). To do this I have to use a linux machine with two network cards. Eth0 will be connected to Router (so I gave it 192.168.254.10) while Eth1 to the lan (so I putted it 192.168.10.10).

I'm working on Slack 8 and I'm totally new to linux (but very willing to learning!!!). :study:

I tried to put on proxyarp (whithout knowing what it is..) and the ipforward to 1. The only result is that everything in the network can ping the other things. :scratch:

Can someone tell me how to configure that well? (I just need to share the net without firewalling for the moment..)

THANKS in advance!! :)

soob 09-16-2003 08:14 AM

Cripes, I forget what proxy-arp is about too. I don't think you need it for what you're trying to do - I have setup a couple of systems like that. Probably you just need to add some forwarding rules in iptables. The best info I've found is here:

http://tldp.org/HOWTO/IP-Masquerade-HOWTO/index.html

Your external interface is eth0, internal is eth1 - a lot of ip masq writeups assume you have a modem but yours is ethernet.

Couple of others, not quite so up-to-date and i haven't read them:

http://tldp.org/HOWTO/Home-Network-mini-HOWTO.html
http://tldp.org/HOWTO/Masquerading-S...WTO/index.html

linuxlois 09-16-2003 08:24 AM

news
 
I let everything pass with the forwarding (input output and forward are accept) and I just add the default gateway (the router ip address). this way the linuxpc can ping everything and can access internet, while a client can ping everything inside the network (even the router ip) but not on internet. :(

Another thing (maybe it's not relevant.. a NAPT is on on the router and if I disable it I cannot connect on internet.. It cannot be set other than just on or off).

:scratch:


All times are GMT -5. The time now is 01:26 AM.