LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-01-2009, 02:53 AM   #1
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Question [Partly SOLVED] Accidentally set ctl-shift-u to enter u. How to reset?


Hello

While working in OpenOffice Writer I accidentally set ctl-shift-u to enter u. Normally it subscripts the selected text.

Turns out it was not an accidental OpenOffice setting because it is also effective in gedit, Gvim and Firefox (used to write the subject of this post).

It's a bit more than simply u; in Gvim, when entered in input mode, subsequent characters are underlined; in OpenOffice Writer the u cannot be selected and entering another ctl-shift-u does not insert another u.

I don't know how to tell if this accidental setting affects text mode: in vim control mode the command s/./ctl-v ctl-shift-u/ results in ^U in the display. In input mode and at the bash command prompt (set for vi style editing) ctl-shift-u clears from cursor to beginning of line/command. Is that normal?

AFAIK the keyboard itself does not have recording/playback facility but it's possible; it's a cheapo with no documentation. FWIW it was made by Chesen and branded as an Anhui K680.

Software that might be doing this is:
  • ubuntu 8.04.1
  • X
  • SCIM 1.4.7 (not knowingly used but is installed)
  • GNOME (2.22.x maybe)
  • Metacity 1:2.22.0

Examining each of these in turn has not identified where the problem setting is made (possibly because of my ignorance):
  • ubuntu: I don't know anything about ubuntu key settings.
  • X: xev (insofar as I understand what it is saying) doesn't show X doing anything special with ctl-shift-u.
  • SCIM: A review of SCIM hotkeys didn't show it using ctl-shift-u.
  • GNOME: System, Preferences, Keyboard Shortcuts didn't show ctl-shift-u and anyway it's all about running commands not entering text.
  • Metacity: gconf-editor, apps, metacity didn't show ctl-shift-u and anyway it's all about running commands not entering text.

The setting is persistent across a reboot

How to find and remove this unwanted configuration?

Best

Charles

Last edited by catkin; 05-05-2009 at 08:18 AM.
 
Old 02-01-2009, 07:33 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Original Poster
Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Unhappy Weirder ...

This is getting weirder ...

Working in an OpenOffice spreadsheet I used ctl-shift-u to superscript some text -- and it worked! Hoping the problem had "gone away" I opened an empty cell for editing, did ctl-shift-u and got u.

Deleted the unwanted u with backspace and clicked in another cell to continue working -- and the u appeared! Clicked around a few empty cells and each time the u disappeared from the last cell and appeared in the new one, almost like it was a new text cursor (except the I-bar text cursor appeared as normal).

Just tried to do the same again to see if it's reproduible and it didn't work. Was same up to deleting the unwanted u with backspace but clicking in empty cells didn't insert it.

Mmm ...
 
Old 02-01-2009, 07:40 AM   #3
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
weird
what distro do you use and what de kde xfce or gnome cos then i can help more
im waiting for your reply
 
Old 02-01-2009, 08:12 AM   #4
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Original Poster
Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Post

Thanks theacerguy

Software that might be doing this is:
  • ubuntu 8.04.1
  • X
  • SCIM 1.4.7 (not knowingly used but is installed)
  • GNOME (2.22.x maybe)
  • Metacity 1:2.22.0

Best

Charles
 
Old 02-01-2009, 08:26 AM   #5
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
Quote:
Originally Posted by catkin View Post
Thanks theacerguy

Software that might be doing this is:
  • ubuntu 8.04.1
  • X
  • SCIM 1.4.7 (not knowingly used but is installed)
  • GNOME (2.22.x maybe)
  • Metacity 1:2.22.0

Best

Charles
ok im used to kde but i should remember how to do this

WAIT I HAVE METACITY I WILL CHECK IN THAT!
WHEN MY ACER COMES BACK FROM REPAIR I WILL BOOT 8.10 AND CHECK IN THAT
glad to help
 
Old 02-01-2009, 10:29 AM   #6
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
ok im back
metacity doesnt work on my machine...
but option 1 is)
reformat your pc...
2
reset ooo back to default by reinstalling ooo
3
check the control center thingy settings
i use kde and suse do have a ubuntu but is in for repairs
will help asap though!
 
Old 02-16-2009, 10:08 AM   #7
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Original Poster
Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Question Bump

Quote:
Originally Posted by theacerguy View Post
ok im back
metacity doesnt work on my machine...
but option 1 is)
reformat your pc...
2
reset ooo back to default by reinstalling ooo
3
check the control center thingy settings
i use kde and suse do have a ubuntu but is in for repairs
will help asap though!
Thanks theacerguy

Reinstalling everything from scratch is a bit drastic for what is only an inconvenience.

Reinstalling OOo is unlikely to help because, for the reasons given in the OP, I don't think this is an OOo problem.

I have already checked all the control centre settings I can think of as described in the OP.

Maybe "do nothing" is the best approach. The problem, at first solid, baecame intermittent and has now "gone away", for the last few days.

Best

Charles
 
Old 04-07-2009, 11:33 AM   #8
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Original Poster
Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Question Problem "gone away"

Hello

This problem "went away". I have no idea what triggered it or what made it go away

Best

Charles
 
Old 05-05-2009, 08:22 AM   #9
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Original Poster
Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Hello

Mea culpa. The shortcut to superscript selected text is not Ctl-Shift-U (sUperscript) but Ctl-Shift-P (suPerscript). That functionally solves the problem leaving only the mystery of what Ctl-Shift-U is doing and why.

Best

Charles
 
Old 05-06-2009, 11:13 AM   #10
amysaraantony
Member
 
Registered: Apr 2009
Posts: 42

Rep: Reputation: 16
When in doubt - Format and re-install !


Debian

Last edited by amysaraantony; 05-15-2009 at 08:10 PM.
 
  


Reply

Tags
gnome, hotkey, keyboard, metacity, scim, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Set wrong resolution in Fedora 10 -- screen black, no automatic reset duffym Linux - Newbie 9 12-01-2009 02:46 PM
SUSE - Root Shell accidentally set to /bin/false LinuxBaby Linux - Server 7 02-21-2008 09:50 AM
Accidentally set CD-ROM driver to ignore. How do/did I change? philc Linux - Newbie 5 05-16-2006 03:40 AM
Accidentally set Grub to advanced... edawad Linux - Newbie 2 01-09-2004 03:57 AM
accidentally reset master boot record jessiscroggins Linux - Hardware 3 06-11-2002 01:32 PM


All times are GMT -5. The time now is 11:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration