LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   a few problems with centos 3.3 / cpanel (http://www.linuxquestions.org/questions/linux-general-1/a-few-problems-with-centos-3-3-cpanel-281779/)

cz1179 01-24-2005 05:51 PM

a few problems with centos 3.3 / cpanel
 
I just got my server reloaded with CentOS from the data center which no longer re-installs cpanel on OS reloads. I installed cPanel myself (which installs by itself with no user input otherwise). I have a few problems here for some reason.

First, APF below giving me errors that I've never encountered before. Second, "make" command does not work at all. Finally, apache shows as failed too in WHM stats.

root@localhost [~]# /etc/init.d/httpd configtest
/etc/init.d/httpd: line 175: /usr/local/apache/bin/httpd: No such file or directory

I went to install APF firewall and got this:

[root@localhost apf-0.9.4-8]# apf -s
/usr/local/sbin/apf: line 281: Pure: command not found
/etc/apf/vnet/vnetgen: line 281: Pure: command not found
/etc/apf/firewall: line 281: Pure: command not found
/etc/apf/firewall: line 281: Pure: command not found

I tried installing mod throttle as well and got this error when I ran 'make'

[root@localhost mod_throttle-3.1.2]# make
/usr/local/apache/bin/apxs -c mod_throttle.c
make: /usr/local/apache/bin/apxs: Command not found
make: *** [mod_throttle.so] Error 127

root@localhost [~]# rpm -q kernel iptables
kernel-2.4.21-9.0.1.EL.c0
kernel-2.4.21-27.0.1.EL
kernel-2.4.21-27.0.2.EL
iptables-1.2.8-12.3

root@localhost [~]# cat /etc/redhat-release
CentOS release 3.3 (final)

I researched on the pure error and found nothing on google, cpanel or rfc site.

I reinstalled 4-5 times already.

My typical APF install (done this a million times, works always except now). Done this on Fedora Core 1, 2, CentOS, Enterprise just fine.

Code:

wget http://www.rfxnetworks.com/downloads/apf-current.tar.gz
tar -xvzf apf-current.tar.gz
cd apf-0.9.4-8
./install.sh
pico /etc/apf/conf.apf
FIND: USE_DS="0"
CHANGE TO: USE_DS="1"

# Common ingress (inbound) TCP ports -3000_3500 = passive port range for Pure FTPD
IG_TCP_CPORTS="21,22,25,53,80,110,143,443,2082,2083, 2086,2087, 2095, 2096,3000_3500"
#
# Common ingress (inbound) UDP ports
IG_UDP_CPORTS="53"

# Common egress (outbound) TCP ports
EG_TCP_CPORTS="21,25,80,443,43,2089"
#
# Common egress (outbound) UDP ports
EG_UDP_CPORTS="20,21,53"

/usr/local/sbin/apf -s
pico /etc/apf/conf.apf
FIND: DEVM="1"
CHANGE TO: DEVM="0"

/usr/local/sbin/apf -r
chkconfig --level 2345 apf on

How do I correct these issues? I obviously do not have ability to "install from cd" as this is a leased server.


All times are GMT -5. The time now is 03:34 AM.