LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-19-2005, 12:37 PM   #1
FUXC
LQ Newbie
 
Registered: Mar 2003
Posts: 11

Rep: Reputation: 0
501 invalid domain name -- when trying to send mail (SMTP)


Hi,

I am fairly new to linux, and I have been using Kmail (1.7) on KDE 3.3 with SuSE 9.1 as my distro. A problem just arose when I try to send mail via Kmail, and I cannot figure out why.

When trying to send, I get an error message that says:

Sending failed:
Unknown error
Unexpected server response to EHLO command.
The server responded: "5.0.0 EHLO requires domain address"
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
RR

---
I receive mail just fine, and strangely enough, right after I open Kmail, it will send my email, but it will get the error every time after that.

I have tried:
"$ telnet <my.smtp.server> 25"
"ehlo foo at bar"

And I get:
501 5.0.0 Invalid domain name

Has anyone heard of this?? Or can anyone get me on track having my email sent consistently?

Thanks a bunch!
Kevin
 
Old 01-19-2005, 02:16 PM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Sounds like you haven't configured your client correctly. Normally your isp will specify the address of their smtp server for outgoing mail and the pop3 address for incoming usually in the format inmail.isp.com for smtp and outmail.isp.com for pop3. Check the configuration under Settings -> Configure Kmail ->network and make sure that they are what your isp has given you.
 
Old 01-19-2005, 02:19 PM   #3
FUXC
LQ Newbie
 
Registered: Mar 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I've double checked the server names, and they are in fact correct (mail will occasionally/rarely send properly). As I mentioned earlier, I had been happily using Kmail for months without any problems and without changing the server names when the error started to occur. Weird eh?

Thanks for your help!

Kevin
 
Old 01-19-2005, 02:52 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Then suspect a server problem with the isp. Check their status and see if they have issued a notice about server problems.
 
Old 01-19-2005, 03:00 PM   #5
FUXC
LQ Newbie
 
Registered: Mar 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I, too, suspected that (even though its usually MY problem). So I checked on a Windows box in my house which also uses the same SMTP server with Outlook, and it worked flawlessly. Grr...

again, I appreciate any help that can be provided..

Kevin
 
Old 01-19-2005, 03:07 PM   #6
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
I am willing to bet they use a linux based server and you can check what they are using via http://www.netcraft.com . The client/os should not affect the way mail is handled.
 
Old 03-07-2005, 11:07 PM   #7
FUXC
LQ Newbie
 
Registered: Mar 2003
Posts: 11

Original Poster
Rep: Reputation: 0
bumping...b/c problem is back

I am back to the original problem as stated in my first post. I never really "fixed" the problem the first time. I basically switched to Thunderbird for awhile, and when I came back to Kmail, email sent flawlessly.

Now, I am back to the same error message. When I telnet into the SMTP server, I can get the same error if I type only "EHLO" and do not include my domain name. I am guessing this is what Kmail is doing, and I'm curious as to how to fix it.

I have the "default domain" properly set in Kmail, and I have toyed with "Custom Hostname to no avail. Can anyone shed some light on this topic?? I've searched extensively and come up with nothing.

Thanks in advance,

Kev
 
Old 05-25-2010, 10:29 AM   #8
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
The HELO that you send is incorrect. Most likely, your comuter has a hostname with an invalid character in it, probably a space.
 
1 members found this post helpful.
Old 05-01-2012, 06:04 PM   #9
mdaum
LQ Newbie
 
Registered: May 2012
Location: Portland, OR
Posts: 1

Rep: Reputation: Disabled
We had this error, and it turned out to be caused by a typo in the hosts file. The "hostname with an invalid character in it" post was the clue. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed to send mail using a remote smtp server with php s1mpl1c1ty Programming 4 09-19-2005 12:53 AM
send mail from workgroup to domain exchange server bharathvn Linux - Software 2 03-28-2005 06:43 AM
smtp problems, can't send mail to other accounts servnov Linux - General 3 09-26-2004 08:17 PM
POSTFIX: Changed SMTP port - now can't send mail (long) cnjvh Linux - Software 1 07-13-2004 01:40 PM
SMTP and KMail and SMTP and Netscape Mail jazz... Linux - Newbie 5 10-11-2003 03:49 AM


All times are GMT -5. The time now is 03:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration