LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-12-2003, 08:13 AM   #1
BlackCell
Member
 
Registered: Nov 2003
Location: Netherlands
Distribution: Debian Unstable
Posts: 61

Rep: Reputation: 15
[sound] Alsa works, speaker doesn't


Hi I just managed to get the 2.6.0-test9 kernel going, with alsa drivers from kernel source (the external ones from alsa-project.org won't compile)

I have sound, as in playing mp3's and stuff,I am happy with that but I am missing my pc-speaker beeps when I for exmple eject or insert a cardbus card, I notice also that the beeps from the terminal aren't there anymore as well, so it seems my pc speaker is "dead", it work when doing the post-beep so it is a linux thingy. To have speaker enabled where do i look or what should I have compiled in the kernel or .. help. I know that most of you don't like the beep I( want it back ;-)

Tx for your thoughts on it.

My config

Debian unstable
kernel 2.6.0-test9
no gnome or kde.
 
Old 11-12-2003, 10:02 AM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
There is a setting in your alsamixer for the PC Speaker, did you set that?
 
Old 11-12-2003, 02:10 PM   #3
BlackCell
Member
 
Registered: Nov 2003
Location: Netherlands
Distribution: Debian Unstable
Posts: 61

Original Poster
Rep: Reputation: 15
do you mean to unmute it? i have done that it is not muted... but still no beeps... I am left a bit clueless...
 
Old 11-12-2003, 04:28 PM   #4
schatoor
Senior Member
 
Registered: Jul 2002
Location: a tiny place caled hendrik ido ambacht in the netherlands
Distribution: SuSE, debian, slackware, lfs
Posts: 1,358

Rep: Reputation: 45
The "problem" you have as nothing to do with alsa. Alsa does nothing with the pc speaker. If you want that, you should compile some other module. But I don't know which one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA works, but sound is EXTREEEMLY quiet!! happyman Linux - Software 9 08-07-2006 11:50 AM
Alsa + sound works on root, but not on users! r4f Linux - Software 2 04-02-2005 05:43 AM
Stereo sound on center speaker in xmms with alsa kule Linux - Software 0 06-16-2004 11:26 AM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 02:34 PM
ALSA sound works...and then goes away bhay Linux - Hardware 3 08-30-2002 05:04 AM


All times are GMT -5. The time now is 07:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration