LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-17-2004, 03:05 AM   #1
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Rep: Reputation: 0
[Question]make initrd error


I complied kernel from 2.4 -> 2.6.3 yesterday

when I first enter linux with kernel 2.6.3 in got some problem

about Modules.

After I install module-init-tools ..the problem went away.

But when I make kernel today to add some config

Everything is fine(menuconfig,make,make modules,make modules_install,make bzImage) before make intall.

I got error when I type make install

error

[error log]

[root@mail linux-2.6.3-1]# make install
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
CHK include/linux/compile.h
Kernel: arch/i386/boot/bzImage is ready
sh /usr/src/linux-2.6.3-1/arch/i386/boot/install.sh 2.6.4 arch/i386/boot/bzImage System.map ""
No module off found for kernel 2.6.4
make[1]: *** [install] Error 1
make: *** [install] Error 2

[/error log]

I think should be mkinitrd error , cause I got the same error message
('No module off found for kernel 2.6.4'),when I use mkinitrd to make initrd.

I don't know if is module-init-tools problm..

Can anyone give me some ideal to solve this problm?
or some URL-info to get new knowledge : )

thx all~
 
Old 03-17-2004, 05:20 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
How did 2.6.4 get involved in this? You're running 2.6.3, right? And you're rebuilding 2.6.3-- aren't you?

So where did 2.6.4 come from?
 
Old 03-17-2004, 09:24 PM   #3
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Cause I change the Makefile ..
In order to not mix with original 2.6.3 I install yestday ^^a
 
Old 03-17-2004, 11:18 PM   #4
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
if you didnt patch the kernel why would you change the 2.6.3 to 2.6.4 .
that is not proper.

you can put 2.6.3-new without having to "mix" anything.

When you compile a kernel of the same version they adont mix. they are seperate entities.


Last edited by AutOPSY; 03-17-2004 at 11:19 PM.
 
Old 03-18-2004, 12:08 AM   #5
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks notice me about this ^^

I will not do this again @@...

It's just a tip for me , Let me not mix with the kernel I install before

Now I know i should change "EXTRAVERSION =" in Makefile

-----

The Question is not solved yet,
I use mkinitrd("mkinitrd /boot/initrd-2.6.3-test2.img 2.6.3-test2")
still get the same error ("No module off found for kernel 2.6.3-test2")

I will check module-init-tools again if is it's problm
 
Old 03-18-2004, 03:36 AM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
What version of module-init-tools are you using?

This thread on the Gentoo forums seems to suggest that the error is caused by versions above module-init-tools-3.0_pre5. So if your version is above that, you might want to downgrade, if possible.

On the other hand, this old mailing list archive speculates that the problem is caused by compiling SCSI support into the kernel, rather than as a module-- and that the kernel is looking for a SCSI module it can't find (because it's in the kernel rather than in the /modules directory).

And lastly, this old Mandrake Cooker mailing list archive post suggests that the issue may be a buggy highmem option in the kernel-- but it refers to older 2.4 series kernels and is probably not relevant to your situation.

So out of the three suspects produced by searching Google, I'm voting for the module-init-tools version and the SCSI thing as the two most worth checking.

I also wonder if you did a "make clean" before recompiling (again) once you had changed the Makefile (back). It's possible that this is an error left over from the original somewhat borked make (since you hadn't had module-init-tools installed, etc).
 
Old 03-19-2004, 12:29 AM   #7
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
hi !~..thx for replying me ~

I use module-init-tools-3.0-pre9 <-My version

I will try to read the infomation you gave

I will post Step when I solve this problm

Thx alot ~
 
Old 03-31-2004, 03:02 AM   #8
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
hi !~
Thx all ...I seems solved this problem
[My Step]
1.Change module-init-tools version to "module-init-tools-3.0-pre5"
2.Change mkinitrd version to "3.4.28-1"
[/My Step]

But It come another problem
After I find in google , I found that I didn't config in loop device option
and then I solve this problem after I recomplie the kernel.
Now I got another problem XD
After I boot from my new kernel It shows "No init found"
[My Grub config]
title REd Hat Linux (2.6.3-test3)
root (hd0,0)
kernel /vmlinuz-2.6.3-test3 ro root=LABEL=/
initrd /initrd-2.6.3-test3.img
[/My Grub config]

I sure that I had been config in my file type (ext3)
I also sure that I will fix this problem , But not today

Thx all again ^^
 
Old 03-31-2004, 04:22 AM   #9
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Does this file

initrd /initrd-2.6.3-test3.img

actually exist under that exact name in the location it is said to be?
 
Old 03-31-2004, 08:26 PM   #10
frid
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
hi !`..thx for reply me~

I think i solve this problem~~

I change grub.conf

[grub.conf]

boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz

title REd Hat Linux (2.6.3-test3)
root (hd0,0)
kernel /vmlinuz-2.6.3-test3 ro root=/dev/hda5
initrd /initrd-2.6.3-test3.img

[/grub.conf]

Donno why can not use orgin set root=LABEL=/

Maybe find the answer other day

Go class ^^ thx all

ps. my hda5 is "/"

Last edited by frid; 04-01-2004 at 01:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I make initrd.img? zahadumy Slackware 2 11-13-2005 10:05 AM
General question while running make "make[2]: *** [main.o] Error 1" matazar42 Linux - Software 3 08-15-2005 01:39 PM
make initrd error imagineaxion Debian 4 02-08-2005 10:29 AM
initrd how to make one? watashiwaotaku7 Linux - General 18 03-20-2004 12:53 AM
New Kernel 2.4.22 won't make initrd jon1591 Linux - Newbie 3 12-13-2003 03:09 PM


All times are GMT -5. The time now is 07:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration